Roon Radio is being limited to my library

Dear all,

having the same issue.
Roon Radio limited to library. Community fixes (Tidal logout in Roon, etc.) didn’t help out.

  • Details on your Core machine (OS, Hardware specs)
    Windows 10 PC - build 18362.720 vers.
    Roon Vers. 1.7 build 528

  • Networking details
    Streaming through Chromecast to Network-Streamer.

  • Audio devices in use
    Pioneer N-70AE LAN-wired to Devolo dlan550duo adapter

  • Library details
    only using Tidal, no local library in use

Timestamp for manually starting Roon Radio from an album (Sgt. Pepper’s Lonely Hearts Club Band (Super Deluxe Edition): 12:56 UTC+1
Link to logs: LINK

Thanks in advance

Hi @Arne_Kaufmann,

I met with the team to discuss this this morning and have some next steps here.

It appears that your machine is having trouble communicating with our servers based on what we are seeing in the logs you’ve shared. Moving forward, we’re running some diagnostics on our servers so we can see what happens on our end when this happens to you. The next time you reproduce this can you please let me know here and tag @support and we will have the team take a look?


Hey Dylan,

sure, occurred now 20:24 UTC+1.

Started Roon Radio from Album. Roon played a title from Album for 1-2 sec. Then it broke up and a message came up that Roon has nothing similiar to play.
Forwarded to the end of the song to activate Roon Radio this way and again the message came up that Roon Radio limited to library.

Besides this error, Tidal is working just normal with Roon all the time.



Hi @Arne_Kaufmann,

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? This will give the team some additional data for their investigation.


Hey @dylan and @support,

I’m a little surprised about your request, as I already shared my logs with you guys with my initial request. I understood, that you wanted to internally work on your servers to find a solution.
However I’m providing todays updated logs: Link to Logs


Hi @Arne_Kaufmann, hi @dylan

It seems to be the same System.Exception as in Roon Radio issues with TIDAL enabled:

I hope it will help you find the cause of this issue.

Thanks, @Arne_Kaufmann.

I’ve passed this along to the team for their investigation and I’ll be sure to update you as soon as I have their feedback.

Hey @dylan

any news?


Hi @Arne_Kaufmann,

Our team is currently investigating this and we have a meeting scheduled with our senior development team to discuss tomorrow.

In the meantime, if you’re interested in helping us better understand why this only affects a small number of customers, I’m hoping you might be able to try a test for us.

If you connect your Core machine via USB tethering or hotspot to a mobile device, does the same issue occur? While this is not an ideal network setup for Roon long-term, this is an easy way to test this behavior on a completely different network.


Hey @dylan,

sure I’ll support where possible. I tried now with USB tethering via my Samsung smartphone and Audio output on my PC Soundcard as well as Audio output via NVIDIA graphics card to my monitor via display port.

Both led to the same old error.

Representative timestamp: 19:32:14 UTC:+1


Thanks for giving that a test, @Arne_Kaufmann. I’ve updated the report with details on this test for our investigation.

I installed Roon just over a week ago. I’m also trialling Tidal.

I experienced the same issue when I first connected Tidal to Roon. It fixed itself the next day.

This morning Roon Radio was working on my phone as an audio output. Then about an hour later I used a different phone to control my 851N network streamer. The issue returned and Roon Radio was limited to my library.

I suspected that Tidal does not allow more than one active playback connection, so I went back to my first phone. On this phone, Roon playback was paused on a Tidal track since there is no stop. I then played a track from my library to get it off Tidal. Then I went back to my 851N and Roon Radio was not limited to my library anymore.

Hope my experience helps with your issue.

Hey @Josh_B,

if this would be the problem, you should encouter this as well with Tidal Original Software, Apps like BubbleUPNP, Audirvana, RemoteControls for AV-Receivers like Pioneer Remote, etc.

Following your idea I tested all of these variants and none of these was giving me the info that due to a parallel playback it couldn’t start.

Further this should then occur as well with Tidal playback without Roon Radio. And again as already mentioned above, this is working well all the time.

Roon Radio is besides some smaller gimmicks the fact why I subscribed to Roon and already payed the yearly fee.

@dylan : For more than two weeks I cannot use Roon now as I intended to, because Roon Radio is the major thing I’m enjoying while using Roon. In case this isn’t working within the next two weeks I expect a voucher or something comparable, because in this case I could have stayed with Audirvana…


Hi @Arne_Kaufmann,

I just wanted to let you know that our team believes they have tracked down this issue and we have a ticket open with our developers. I can’t provide any specific timeframes just yet but we hope to have something available soon and we’ll be sure to keep you updated!

Hey @dylan,

any news? As I didn’t receive feedback now and am not able to use that program as I intended to, I’m asking you now for compensation.

We users have to pay in advance, but in case that the software is not working, partially or in critical cases totally, money is lost. I’m not ok with that and when I subscribed, I did this in the expectation to use it as it was provided within the test period.

Best regards

Hi @Arne_Kaufmann,

Our team let us know that they published a change this evening to our servers that should resolve this. Can you give it a try and let us know if things are working for you now?


Hey @Dylan,

now on the first try it seems to work out well.

I will test it more intense within the next days and report latest next week if anything changed concerning the user experience.

Thank you very much, as it’s looking promising.
Greets Arne

Hey @dylan,

tested a little bit now and with most Albums it’s working well.

Then following happened:

I chose the album “1917 (Original Motion Picture Soundtrack)” and received the message “Roon Radio limited to library”. UTC+1 16:12:47.

So I switched from LAN to USB Tethering and again with this album received the message “Roon Radio limited to library”. UTC+1 16:16:42.

Switching back to LAN and another Album e.g. “Black Sea” (Original Motion Picture Soundtrack) it worked out well again.

Is that normal behavior that in some cases, Roon doesn’t find anything (bad meta data etc.) so it drops this message?


Hi @Arne_Kaufmann,

Yes, there may be some cases where we have limited data that prevents Radio from starting and you get this error message legitimately. That said, we are always getting new data so for albums where this is an issue it can go away on its own.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.