Roon Radio issues with TIDAL enabled


I have the same problem with roon radio and I also have a test licence and Tidal configured in services. When I try to start roon radio from any genre/artist I get the same error message. The first song is in the queue but stopped. As workaround I can remove Tidal. Then roon radio works fine but only wit songs from my local library. When I add Tidal to the services I get the error again. So it seems to be a problem with Tidal support in roon. Is there any solution so that I can still use Tidal? Roon is a nice tool but without Tidal I will probably don’t use it. My Bluesound or Sonos app has no problems with Tidal but it would be nice to combine both in one solution like roon.

Hi @Dawid_Kotlarz,

What kind of Core do you have for Roon? A Windows, Mac, Nucleus or something else?

Is there any change in behavior if you log out of TIDAL and back in via the Roon Settings -> Services tab?

Hi @noris,

The Core is running on a Windows 7 PC:

If I log out of Tidal then roon radio works fine but only with songs from my local library. When I log in to Tidal I get the error again.
I also tried to deactivate the TeamViewer VPN adapter and antivirus program but it didn’t help.

Hi @Dawid_Kotlarz,

Does the same behavior occur for multiple zones or is it localized to just one zone that is impacted by this behavior?

What does your network setup look like? Can you let me know the model/manufacturer of all your networking gear as well as how the Core is connected to the network (is it using WiFi/Ethernet)?

Hi @noris,

I have 3 zones (Bluesound Node 2i, Sonos Connect, Sonos Play 5). The same behavior occurs in every zone regardless of whether I use the controller on my PC or Android phone. Everything is connected using Ethernet except my phone (WiFi):

I also installed Roon Core on the PC controller (Windows 10) but got the same issue.

The issue might be with the pfSense Firewall/Router. Try taking it out of the equation as a test.

I cannot change the router so easy. Does roon need some special settings in firewall etc?
(I changed Tidal to Qobuz in services but it didn’t help - same issue).

I am not sure what if any special settings are needed for Roon/Tidal. But, if you think about the issue, the Radio issues occurs when the RoonCore has to reach out through the router to the internet in a timely fashion.

You might try setting your DNS to or if they are not already; as sometimes slow DNS responses can cause issues.

Hi @Dawid_Kotlarz,

This is a good step, sometimes ISP-provided DNS servers don’t work too well, so changing to Cloudflare/Quad9/Google DNS is worth a try.

You could also try simplifying the network a bit here, if you conenct the Core to either the pfSense router directly or to the Netgear switch (instead of the TP-Link), is there any change in behavior?

Hi @noris, hi @Rugby

My DNS Server list looks like this now: (pfSense has also a local DNS service with DNS resolver)
But there is no change in behavior.

I tried something similar. I disabled ROON Core machine from picture and installed Roon Core on the PC marked as “PC controller” (Windows 10) but got the same issue.

I found that sometimes it works when I start Roon Radio from the PC controller. After the error appears (“Unexpected error: Limiting roon radio to library”, “Roon Radio: Nothing Similar To Play!”), I have to replay the track from the queue. Sometimes roon radio finds the next track when I press next and the radio works

If this is a problem with a timeout when the core tries to reach Tidal / Quobuz, is there any way to adjust this timeout in the core settings (5000ms, 10000ms)?

It’s just a problem with Roon Radio. Playing albums or playlists works fine.

Hi @Dawid_Kotlarz,

Thanks for checking the DNS aspect and the PC Controller.

I’d like to take a look at diagnostics to see if we can gather a more precise error message.

Can I please ask that you reproduce this behavior on your Windows 10 PC Controller and note the exact local time + date + track you experience this issue with?

After, can you please access your Roon logs by using these instructions and provide a set via Dropbox/Google Drive? If you don’t have either file sharing service just let me know and I can provide an alternate upload means.

1 Like

Hi @noris,

Yes I can do this but I need some alternate upload means.

Hi @Dawid_Kotlarz,

I have just sent you alternate upload instructions via private message - the green “1” in your notifications area of this site.

Hi @noris

I uploaded the logs. Here are the steps from my test:

I went to genre/jazz and started roon radio. It chosen the song St. Thomas from Sonny Rollins from Qobuz and stopped immediately and I got the message “Roon Radio: Nothing Similar To Play!”. I pressed play and the song started to play.
22:08:18 (UTC+1) - I pressed “next” and got the error “Unexpected error: Limiting roon radio to library”, “Roon Radio: Nothing Similar To Play!”
22:09:00 (UTC+1) - I pressed “next” again and got the error “Unexpected error: Limiting roon radio to library”, “Roon Radio: Nothing Similar To Play!”
22:19:15 (UTC+1) - I tryed this with “blues”. It chosen the song from Qobuz. Pressed “next” and I got the same error.
22:21:30 (UTC+1) - I tryed this with “rap”. It chosen the song In/Flux from DJ Shadow from TIDAL. Pressed “next” and I got the same error.

Thanks for your help!

In Roon Server log I found this:

–starting roon radio–

03/20 22:06:45 Debug: [easyhttp] [448] POST to returned after 655 ms, status code: 500
03/20 22:06:45 Warn: [mlradio] [5] [music/mlradio] _GetNextItems Failed: System.Exception: /session/continue failed: 500
at Sooloos.Broker.Music.Radio.SwimProxy.d__10.MoveNext()
— End of stack trace from previous location where exception was thrown —

–pressing next–

03/20 22:08:16 Trace: [NODE 2i - A9B8] [Lossless, 24/96 QOBUZ FLAC => 24/96] [100% buf] [PLAYING @ 1:14/6:47] St. Thomas - Sonny Rollins / Doug Watkins / Max Roach / Tommy Flanagan
03/20 22:08:20 Debug: [easyhttp] [489] POST to returned after 5439 ms, status code: 500
03/20 22:08:20 Critical: [mlradio] [6] failed to init swim: System.Exception: /session/begin failed: 500
at Sooloos.Broker.Music.Radio.SwimProxy.d__8.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.TaskAwaiter`1.GetResult()
at Sooloos.Broker.Music.Radio.MLRadioSession.d__36.MoveNext()

It looks like my Roon Core is trying to continue/start a session on your server with a POST request (, but this is failed due to an internal server error on

The same error: Roon radio only limited in Library

Hi @Dawid_Kotlarz,

Can you please try rebooting your Core and verify if the behavior is the same even today? A 500 error indicates that the issue could have been from our server’s end, I would try starting Radio again. Do let me know if it’s now working.

Hi @noris

No, Roon Radio still won’t work if it’s not limited to the library. I think you can find the reason for http status 500 in the server log as this is where the error came from.

Current timestamp for the error is 03/23 23:13:50 (UTC+1)

Hi @Dawid_Kotlarz,

Do you by any chance have a hostpot capability on one of your phones? I wonder if your network setup is related to the issue at hand, and this would be the easiest way to verify.

A post was split to a new topic: Roon Radio Issues with Starting