Roon Radio: Nothing Similar to play! Nucleus+

Roon Core Machine

Roon Nucleus+
Version 1.0 (build 227] stable

Networking Gear & Setup Details

Sophos Router

Connected Audio Devices

Ethernet connected

Number of Tracks in Library

I don’t have any tracks in my library

Description of Issue

I experience the ‘Nothing Similar to play’ issue regularly. Here’s the latest example:
Artist: Kenny Wayne Shepherd
Song: Blue on Black
When I try to start Roon Radio from this song, I get the error message

Other artists work fine. Here’s an example:
Artist: Yes
Song: Hearts

Blue on Black is not an obscure track so I’m puzzled why Roon Radio doesn’t work for that song. I really like the Roon Radio feature and it is so frustrating when it doesn’t work because I want to experience new music.

How did you queue up the track to start the Roon Radio?

I searched on Kenny Wayne Shepherd Blue On Black and selected the album cover listed in the response. From there I used the Play now drop down and picked Start radio. It worked for me.

Tried again with Play now and Roon Radio picked the same followup artists.

I know this doesn’t help you. Was trying to get the same results as you did.

I only get this when I’m having issues with one of the streaming providers. Have you tried all the normal tricks like setting DNS to

What streaming service do you use and in what country?

DNS is already set to I live in the US. My music service is Qobuz.

Is this in your local library? If so, is the album identified or unidentified. If unidentified, Roon Radio will not find anything to play since it doesn’t know what the album is.

Hey @Eric_Tykeson,

Thanks so much for sharing the behavior you’re experiencing now and then - we’re sorry about the trouble!

I was wondering, since this thread was created, have you experienced it again? Could you please share an update? We’d love to help if we can :nerd_face: