Roon Radio: Nothing similar to play! - Please help

Hi
I started my Roon trial a few days ago and i’m pretty pleased with everything thus far.

However, I just cannot get Roon Radio to work, when I pick a track and select the Roon Radio option - a message appears saying that Roon Radio has started and then a second later the message 'Roon Radio: Nothing similar to Play!

I have installed core on my desktop and use an ipad and iPhone as remotes. This issue appears when im playing through my desktop and through all other players (main player is Cambridge Audio CXN V2)

I have a Tidal subscription and my music library is on a vortexbox.

I have tried rebooting core (I assume this is just restarting my PC?)

Please help.

Thanks
Rich

1 Like

Provide an example track. Is it on Tidal or your own file?

Hi Henry
Just tried it on the album ‘A Jug Of Love’ by Mighty Baby on Tidal (so clicking on the drop down next to ‘Play Now’ and selecting Roon Radio)
And on several albums in my library - nothing working

I found this post while searching for a solution because I have the exact same issue. I also just started the trial yesterday, and I also have it connected to Tidal.

My Roon Core is installed on a dedicated Debian Linux VM. Message happens on Windows and Android Roon apps when trying to start any radio from Artist, Album, or Track. The issue happens regardless of whether trying to start radio from local files Library or from Tidal.

I also tried rebooting but that didn’t help. I’m stuck.

Same issue here. Tried rebooting with no luck. Core is installed on a MacBook Pro. Radio does not work from iPhone, iPad, or MacBook Pro. Tried playing from my library, Tidal, and Quboz.

Thank you for any help you can provide!

Hi

All sorted now!

I checked my anti virus and firewall settings - bingo!!

It was blocking bits of Roon, allowed an exception and its been working perfectly ever since.

Hope that helps others.

Cheers
Rich

1 Like

Mine appears to be working now, too. Your comment about Roon being blocked got me thinking about my setup using a PiHole DNS filter. I set my Roon server to bypass it for DNS and now radio is working.

I’ll try to update if things stop working again.

1 Like

Nothing similar to play. Please help

Roon Radio has been working fine for me but this morning I got the message “Roon Radio: nothing similar to play” on one track:

TIDAL “Trash TV” by Souveneer

I see the comments to adjust firewall settings, but this is on a Nucleus and isn’t a problem on other tracks so I think it’s probably track-related. Any ideas, or does Roon Radio just give up some times? The song is listed as both “Pop” and “Pop/Rock” genres, so I would think that would allow SOME sort of match.