Roon Radio Queue shows wrong now playing songs

Roon Core Machine

Roon Core is ROCK on NUC, Version 1.0 (build 227) stable. Roon Server is Version 1.8 (build 884) stable.

Networking Gear & Setup Details

Mix of ethernet and wifi. For this issue, streaming over Orbi wifi via Sonos streaming to Sonos Port.

Connected Audio Devices

Sonos Port for this endpoint.

Number of Tracks in Library

14,275 tracks

Description of Issue

When RoonRadio starts at the end of an album, it plays a few songs and sooner or later the queue is out of sync with what is ‘now playing’. Now Playing and the progress indicator show a song three or four ahead in the queue, while the sound is playing a song three or four back.

For example, in the image below, it says and scrolls playing “Eastern Pleasures” by Michelle Malone. In fact, it is playing “Where Would I Be” by Nanci Griffith.

This frequently happens, and gets worse (more out of sync) over time.

Any help appreciated.

Hi @JeffN,

Thanks for getting in touch with your report. This one is a bit strange isn’t it? Are you still seeing this behavior of Build 898?

I have a few additional questions for you:

Is your Roon Core wired directly to Ethernet?
Is this behavior demonstrated on all your endpoints or only certain endpoints?

We’ll be watching for your response and get back to you as quickly as we can. Thanks!

Have you tried a reboot to clear it?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.