Roon Radio & TIDAL

iMac, latest Roon, iPhone 6S+, Melco N1A, Ayre QX-5 Twenty, Apple TV

For unexplained reasons, my Roon server stopped being able to see or steak to my current-generation Apple TV. It all otherwise works as expected. I rebooted everything and installed fresh software; and it all works fine except that I can’t stream Roon through my Apple TV. It used to work great, just a few days ago.

Hi @Robert_Schaub,

What is your network setup like? Can you please list the model/manufacturer of your networking gear and how your Core iMac and Apple TV are connected to the network?

If you have any other Airplay zones - are you still able to properly see these in Roon Settings -> Audio and just the Apple TV is missing?

Apple AirPort Extreme hardwired through RJ/E cables to the Apple TV. Yes, I can see the other AirPlay and Chromecast Zones, some hardwired and some WiFi. It worked until I updated Roon.

Hi @Robert_Schaub,

Thanks for those details.

You should be aware that we strongly suggest staying away from Apple Networking Gear, as we have often seen poor performance from these types of devices, as mentioned in our Networking Best Practices Guide:

Finally, we strongly recommend against using Apple network devices such as the Apple Airport Extreme and Airport Express (note: it’s fine to use the Airport Express as an Airplay device). To ensure the best performance, we recommend against using these devices.

I am not saying that this is the definite cause just yet, but it is something to be aware of as we dive deeper into troubleshooting.

To clarify here, did you try re-installing Roon itself with a fresh database? I would give this a try:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the same behavior occurs without restoring your backup just yet
  • After confirming if the fresh database works as expected, you can try restoring your backup

This is way more elaborate than should be required. Things were working fine. I updated Roon. Things stopped working in that I can’t support my current use case, streaming music with Roon under Apple TV. Please let me know what I can do to fix this. “Reinstall everything” is not a very good answer.

HI @Robert_Schaub,

You mentioned that you rebooted everything and installed fresh software, but I just wanted to check to see if you set the old database aside when you reinstalled, as setting the database aside might help.

What does your Settings -> Audio tab currently look like? Can you please share a screenshot of it?

I wound up forcing a system refresh by wiping, reinstalling, and fully resetting the Apple TV. That woke everything up. It was simpler albeit less elegant than checking piece by piece, and it worked.

1 Like

That’s fantastic news @Robert_Schaub, do let us know if you run into any other issues with Roon and we can take a look!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.