Roon Radio Turns On by Itself

This may or may not be related, but over the past 10 days or so, Roon has been turning on Roon Radio all by itself. First use each day normally reveals this; I switch it off, it comes back on. Is this related to the diagnostics?

Hi @Vaughan_Barnacle,

Thanks for clarifying the back behavior, I have added this to your case notes.

No, this is not related to diagnostics being active on your Core. Are you performing any specific action right before this occurs such as rebooting the Core?

The core is switched off every night, but this hasn’t been an issue before. Does seem to happen with the first use of the day, though.


So, the issue with Roon Radio automatically turning itself on occurred again today (9 October) at about 14.04 (British time).

With regard to the advice on trying to run Roon Core on another machine (my Windows desktop): I have said before that this isn’t possible, because my DAC doesn’t have wi-fi and can only connect via a usb cable. The desktop is about 20 meters away in another room.

We may have to admit defeat on this issue, because we seem no closer to a solution and I have a life to lead. Roon is supposed to make life easier, not harder.



Hi @Vaughan_Barnacle,

I wanted to check in to see if you have had a chance to run your PC as the Roon Core and maintain your Nimitra as an output device as well.

I spoke to QA regarding the other issue you reported of Roon Radio turning on again and they have a few follow up questions:

  1. Can you confirm that this is the exact error behavior?
A. Disable “Start radio when the music ends feature“ on the Queue screen for a certain zone

B. After some time the machine that runs the server Radio is turned on again
  1. Was Radio turned on for the same track that was previously playing (as in you pressed the play/pause button for playback to resume)?

  2. Did you only notice this behavior when you started a new track selection? If this behavior only occurred after making a new selection, how did you start the new selection? Did you press “Play Now” or “Roon Radio” after right-clicking the track/album?


I simply selected an album from album view, selected play now, and when it finished, I noticed more music playing. Didn’t go anywhere near the queue screen or the roon radio controls. It just turned on automatically. Very strange.

There is an option called Roon Radio which is set to ON as default. This takes the last song played and begins playing music like it. You can turn it off under the Queue screen on the right hand side.

Yeah, I’m aware of that. It was the first thing I turned off when I subscribed to Roon. It keeps turning itself back on, though.

The setting is not universal. It needs to be set per zone.

Hi @Vaughan_Barnacle,

I have split the Roon Radio issue out from the focus issue so that we can keep the two issues separated. I have tried to reproduce your report on my end of using Play Now on the album screen and I’m not seeing Roon Radio turn on by itself after I have disabled it for a zone, even after rebooting my Core.

I’ve noted your remarks in the internal ticket you have open, but if you can possibly share a video or .GIF of this behavior it would be helpful. Also, do keep in mind that as @Rugby mentions, this setting is applied on a per-zone basis and disabling Roon Radio for one zone will not automatically disable the feature for all your zones.

I have one zone.

So the issue recurred today. I will post snapshots from my Android (Samsung Galaxy) Roon Remote. Weirdly, the ‘now playing’ screen was showing the wrong track. It was a piano concerto playing, not the Faust opera. But the Roon Radio button had come on all by itself. I find this all very odd. It’s as if Roon is rebooting itself to its original start-up state every now and again.

Hi @Vaughan_Barnacle,

I know it’s been a while since we last spoke, but I wanted to check in with you to see if this issue is still occurring, even on newer versions of Roon?

If this issue is still ongoing, is it only impacting the RME ADI-2 Dac zone or does it also occur on your Android phone’s system output?

Yes, it’s still an issue, across all my android devices. I had hoped that the latest Roon update would have cured it, but sadly no.

To be clear, I havdn’t tried listening via anything other than the RME dac. Switching the core didn’t help, though.

Hi @Vaughan_Barnacle,

Thanks for confirming the Core aspect, but what we would really want to know here is if this issue occurs for multiple zones or just the RME. Can you please try another zone such as your Android’s internal speaker output for a day or two to verify if the same issue occurs there?

I will need some guidance on that. The RME dac isn’t networked, and I just have my phone set up as a Roon Remote. There’s too much assumed knowledge here.

Hi @Vaughan_Barnacle,

To play to your Android speakers, you first need to activate the zone in Roon Settings -> Audio (on the android app), and then press the “speaker” icon in the bottom right of the app -> switch zone -> select android zone from there. If you disable the Roon Radio feature (go to now playing -> Roon Radio -> off), does it automatically re-enable for this zone?

Ok, so I’ve tried playing Roon out of my Android device, with the same issue. And the related issues that I’ve had recently are still there too: being unable to use the back button on the Android button after the music has finished playing, and not being able to use the album view either, because it says there are focus criteria in play, and returns 0 albums, even though I’m not trying to search.