Roon radio: unexpected error: Error Limiting to Library (2019-06-00)

Core Machine (Operating system/System info/Roon build number)

Macbook air as core/server. Downloaded the newest version. (416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wifi but same issue with lancable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Happens on Majik DSM, bt also when I play through macbook itself

Description Of Issue

Some time ago, when I searched for Andrea Bocelli, clicked on the artist and clicked on ROONradio, the radio would start.

Now I do get: nothing similar found.
When I press it again, I do get:
Expected error: limiting roon to library.

Sometimes when I keep pressing, sometimes it suddenly works. But sometimes it works for 10 secs, and I get nothing similar found.

I do use Roon with Qobuz, and no local files.
Weird thing is, this worked till some weeks ago.

When I select a specific album from an artist, and then select roon radio it does work in 30% of the cases…
But when I select another album, or sometimes the same album again, I do get the same error message. What todo??

Hi @LinnDre,

Can you provide some additional details about the networking hardware that is in use here?

Just to verify, this happens with all artists, tracks, and album when trying to start radio and not just Andrea Bocelli, correct?

Have you rebooted the roon server?

Yes rebooted the MacBook. Updated etc. Nothing changed.

Modem/router ziggo technicolor TC7210.
Keeps saying nothing similiar. And not just with Andrea Bocelli.

Next thing. Try logging in and out if Qobuz in settings, services. These are the common troubleshooting steps. Will help support narrow down the problem.

Yes I did this based on another complaint from someone on the forum. Still did not help

It sounds like roon isn’t getting through with its network queries perhaps. Support may need to turn on diagnostics. One last reboot suggestion, if you haven’t already, try the router.

Hi @LinnDre,

Often times this type of behavior is stemming from a networking issue which is preventing your Core machine from properly communicating with our servers.

Do you have any active firewall or antivirus on the Core machine? Does disabling it yield any different results?

Had Radio been working for you previously or has this always been the case since 1.6 was released?

Hi Dylan,

I’m currently seeing this too.

Cheers, Greg

2 posts were split to a new topic: Radio is being limited to library

This issue seems to have resolved itself for me.

Cheers, Greg

Thnx. No AV or firewall active.
I Also have set my phone as WiFi hotspot over 4g to exclude my router. Same issue.

Issue was not here before. And yes 1.6 was working before. No idea what this is causing it :frowning:

Thanks for the details, @LinnDre.

Moving forward, I was hoping you could do the following:

  • Navigate to Abbey Road by The Beatles (an album we know is popular and Radio has a lot of data on)
  • Start Roon Radio for this album
  • Make a note of the time that you see the limited to library error message

Respond here with that time and your timezone and we will enable diagnostics on your account.


Hey. The first 2 times it worked. 3rd time same error. 9:16 dutch time.

When I search for beatles and click radio from there IT never works.

Hi @LinnDre,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Update — The diagnostics report was received and passed to the team for analysis.

I generated the errors again.
Ignore not logged into qobuz. I did that after the restart.

After a day it seemed much better. Any idea what the log said?

Hi @LinnDre,

I’m glad to hear that things are running better now! The team analyzed the logs and we currently have a meeting scheduled to discuss further later this week. If you see this issue return please let us know!

Curious what you Guys/girls will find. If you need more debug/testing from me, let me know!


I am now getting this issue but strangely it appears to be only on the Classical Catalogue, everything else works fine including the Abbey Road test. On the Classical catalogue I get Unexpected error limited to library and if I play a track through Roon Radio I get Roon Radio:Nothing Similar to Play!. Always been ok before.

I use Qobuz streaming and my own ripped and downloaded library. Everything has been rebooted but no change.