Roon randomly skips Tidal tracks

Core Machine

Physical host:
HP Z230 SFF Workstation, Intel Xeon E3-1225 V3 Quad core 3.2 Ghz, 32 GB DDR3 Unbuffered ECC Memory.
500 GB WD Red SSD + 250 GB Samsung 850 Evo + 4 TB WD Red 7200 RPM HDD.
VMware ESXI 7.0.0 Build 15843807)

Virtual machine:
2 virtual cores, 2 GB RAM, 16GB storage running on WD Red SSD.
Ubuntu Server 20.04 LTS with latest software (Roon installed via automated install script:

Network Details

Ubiquiti UDM Pro
2x Netgear ProSafe 24 GbE unmanaged layer 2 network switches.
Not using WiFi for streaming, so not applicable.
1000 Mbit/s down and 50 Mbit/s up from ISP.

Roon server is on the same subnet as the clients and streamers.

Client device

i9 9900k 16 threads @ 5.0 Ghz, 32 GB DDR4 non ecc, wired gigabit ethernet connection.
Windows 10 Professional 64 bits operating system
Latest Roon version

Audio Devices

AudioQuest Dragonfly Cobalt on Windows 10 machine.

SimpleAudio Roomplayer+ with Reloaded+ software.

Logitech Transporter

Description of Issue

Roon randomly skips tracks when playing from Tidal, I monitor my internet connection, it has 0.00% packet loss over the past 10 days. I’ve recently reïnstalled Roon on a new virtual machine, but this behavior has been present on my Roon system for the past 3 months for sure. It is a lot better then it was before, but still seems to occur.

Also my internal network has 0.00% packet loss, this is not the issue for sure. I’ve taken a look at the Roon logs, please see below for the error.

I’m not comfortable sharing the entire log on this community, if necessary I will send it to Roon tech support itself via private message or whatsoever. Since I’m unsure how much private data is included in the logs like my email address, Tidal account, IPv4 address etc. Don’t want to read all the lines and filter this :slight_smile:

As far as I can tell there is some sort of issue with buffering the audio on the core server and transporting it to the end device, in this case my Simple Audio Roomplayer+ running RoonBridge (This device is basically a Linux computer).

If you require any additional information please let me know!

Kind regards,


Please see the attached image. Apologies for not being able to paste the text, the topic create tool doesn’t allow me to. It gives some sort of error message about not allowing more than 2 links in one topic for new members, however there are no Web URL’s in the logs.

Hello @Felix_Hendriks,

Words fail me in trying to apologize for how long it took us to get back to you. I am so sorry :pleading_face:

We appreciate you choosing to let us know of the issue you’re experiencing and sharing all the detail that you have already.

If this is still ongoing, we’d love another chance to help :nerd_face: . Could you please confirm if the skipping happens only when streaming to your Simple Audio Roomplayer+, or to all your audio devices? Also, if you try streaming directly from TIDAL, do you get any skipping?

I’ll keep my eyes open for your reply :pray:

Dear Rebeka,

The past few weeks, I believe after a Roon software update, I haven’t yet noticed the issue. So far so good, which is nice. The issue wasn’t happening on the Simple Audio Roomplayer+ only, it was on all my Roon devices. PC, Phone, Multiple streamers etc. Also the issue wasn’t there when playing from Tidal directly. However it seems to be resolved.

I have another question, normally I would open another thread but since it takes a long time I’d prefer to ask it here.

When using Roon there are some albums which have songs which are marked as ‘Unavailable’. When playing in Tidal this is a non issue, only happens with some albums in Roon. I’ve found that there are already multiple threads on the Roon community forum with people experiencing the same, but no real solution.

It’s only with a few albums in my library, but it does seem a bit weird. In this case the other versions of these specific songs (in different albums) I am able to play. However I’m unable to play them from this album specifically. Also I’ve tried adding this specific album multiple times, clearing the Roon cache and tried different versions of the album. In all cases the issue remains.

In Tidal I am able to play these specific songs from this specific album in my library.

If possible it would be awesome to have fixed. Once again it’s a small thing for me, but I read that other people do experience some serious issues with this.

Roon says tracks unavailable - #18 by Brian_Robbins1 (These solutions didn’t work for me so far).