Roon reacts very slowly

Core Machine (Operating system/System info/Roon build number)
Intel NUC Kit NUC7i7BNH running Rock Version 1.0 (build 227) stable, Roon Server Version 1.7 (build 667) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
DSL Router FRITZ!Box 7590, NUC and PC connected via Netgear GS105E

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Issue is independent of device. Happens with playing local on iPad via WiFI, via HifiBerry Digi+ connected via LAN and local Windows 10 PC, connected via LAN

Roon takes > 15 sec. to open albums and also > 15 sec. to play tracks, even on consecutive tracks on the same album.

Using only local library containing 9800 albums and 228000 tracks. Music files on a WD 8 GB USB-Drive connected to NUC via USB3.

I could compare response times with JRiver on my Windows PC (there I have Roon and JRiver running in parallel). Doubleclick on any track in Jriver leads to instantaneous playing while it can take ages with Roon to start playing. Some tracks in Roon start quicker than others but in general it takes up to 30 sec. for a track to start.

Hi @Klaus_Kammerer1,

Is Roon consistently this slow or does it vary?

If you reboot the Core is there any improvement, even if temporarily?

1 Like


Rebooting the core seems to improve it a bit for the first 5 to 10 tracks , but it is not improving it consistently.

In general, reaction time varies significantly from track to track with no conceivable pattern. Some tracks react very quickly some take very long to start. It is especially annoying within an album if listening in correct order of the tracks - some tracks follow each other without break, some have >15 sec pauses.

Have you tried rebooting your Fritzbox router?
As well you can try a reconnect, see screenshot:

By clicking on the “Reconnect” button, the Internet connection is briefly disconnected and then automatically restored. The FRITZ! Box usually receives a new IP address and a new IPv6 prefix from your internet provider.

1 Like

thanks for the suggestion. I do reboot my FritzBox on a regular level anyway, but that does not improve Roon performance

You may try to connect the NUC to your Fritzbox via Lan and leave out the switch!

NUC and PC connected via Netgear GS105E


I may try that.I did have it connected directly to the FritzBox in the past, but I had very slow data transfer speeds when moving my local library files to the disc attached to the NUC. Routing it via the switch increased the data transfer speed significantly

Ah - a managed switch, I believe. I bet that’s the cause of your troubles.

1 Like

@Geoff_Coupe thanks for the hint. In fact, I was not aware that GS105E was a managed switch. I have another Netgear in stock which is not managed. I will exchange and report.

You may also try another cable or another fritzbox lan port …
Also have a look here:

thanks - but why would this influence performance on playing my local library? In my current setting I can copy and access files with much more speed than required for playback.
Excuse my layman approach, but I am not a network expert.

I have exchanged the switch to an unmanaged one but the problem still persists…

And rebooted everything? (NUC, PC and Fritzbox)

1 Like

Hello @Klaus_Kammerer1, have you tried temporarily disabling your firewall/antivirus to see if this makes a difference? Lastly, could you please reproduce the issue one more time and reply here with a timestamp of when the issue occurred (in your local timezone) and the track that you noticed the issue on? I’d like to enable diagnostics for your device, thanks!

1 Like

@Geoff_Coupe rebooting the NUC seems to have done the trick for the time being. I had restarted Roon Server several times, but forgot to reboot the NUC. Thanks for the advice.

@nuwriy will do if it should happen again. Is there also a built-in Firewall to disable if I use Roon on my iPad? I can try to disable it on my Windows PC but I’m at loss what to do on the iPad.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.