Roon reads only a portion of my library

I have QNAP NAS, formatted RAID5. I copied my music to it. I have file sharing on, including SMB and AFP.

I have tried importing my entire library at once (127k files), but that has been a disaster. At the suggestion of the Roon community, I tried importing a subfolder within my music. It has 21,407 files. All the music is in either 16- or 24-bit FLAC format.

After the first scan, only 4,411 files were imported. So I did a rescan. It went up to 6,715. I did this a total of six times until Roon seemed to be stable at 14,935 files. A quick look and I determined that fully 25% of the albums are missing from Roon. I checked the NAS and the missing files are where they are supposed to be, that is, Roon just cannot import them. There is no reason from their names (which are sequential) why they were not imported. I also checked the “skipped files” folder and they are not there. It is as though Roon simply doesn’t know these albums exist.

As a next step, I shut Roon down and erased the three albums that could not be imported from the NAS. I then reloaded them to the NAS and did a seventh forced re-scan thinking that now they would be picked up as a new addition, This time, Roon told me I had lost two albums (I have no idea which ones) and I had fewer files than before. I removed them again, changed their names, put them back on the NAS and did an 8th rescan. They are still not there, nor arthe additional two lost albums.

How can this be solved? I have too many albums to keep track of; I chose this subdirectory to experiment with because the album folders have sequential names and I can see what is missing. Yet after eight rescans, a very large portion of my music is not being recognized. How can Roon be trusted if it doesn’t pick up a good 25% of the music? Does anyone have a solution for getting Roon to find music it seems to think is Dark Matter?

As it seems to me you’re in need for support, I moved your post to the support section of the forum.

Please add the missing information about your setup and gear by filling out the support template:

Core Machine: MacBook Pro.

Network Gear: WiFi, whatever router ATT supplied, my NAS is connected by a LAN chord to a tp-Link MU-Mimo wifi range extender; I believe I have 2.4 GHz/800 Mbps service but it could be 5 GHz/1733 Mbps. My NAS is a QNAP TBS-453DX with four Samsung 2 TB SSDs, configured in RAID 5. I have no problem accessing my NAS and storing/running things on it, except for Roon!

Audio Devices: Not relevant yet. I am talking only about organizing and recognizing the library. I have a Roon endpoint device by BluSound, but I haven’t hooked it up yet.

My problem is that Roon imports only a fraction of my library. It doesn’t see all of it.

Have you tried connecting the NAS directly to the computer as a “big hard drive”

Connection via the network stuff may be an issue?

Doesn’t seem to be the issue. There are no problems moving stuff to the NAS or retrieving them. Except through Roon.

This is likely to be your problem, right there. Try connecting the NAS and Roon core to the same wired network via a gigabit switch. WiFi is not a great way to try ingesting a library into Roon, much less so via a Wi-Fi extender which halves WiFi bandwidth. And for the purposes of ingesting your library turn Analysis off.

Hello @Geoffrey_Braswell,

Can you please provide a few screenshots of how your music folders are labeled?

Do your files/folders contain any special characters in them?
https://kb.roonlabs.com/Skipped_Files:

Special Characters

Avoid using “special” characters in the names of files and folders. Using these characters may render the files inaccessible under some circumstances, particularly if files are transferred between different platforms, or viewed over a network share.

< (less than),  > (greater than),
: (colon - sometimes works, but best avoided),
" (double quote),
/ (forward slash),
\ (backslash),
| (vertical bar or pipe),
? (question mark),  * (asterisk),
$ (dollar sign),
` (backtick), and 
~ (tilde)

Sometimes the presence of one of these characters causes Roon to be unable to “see” a file or folder in the first place. Files skipped for this reason do not (and can not) show up in the Skipped files list, since it may not even be possible for us to know their name.

I would also try the suggestion of connecting the NAS directly to the router and temporarily bypassing the range extender, we have sometimes seen strange behavior surrounding

Another thing that can cause missed items is permissions on your folder shares on the NAS unless everything is under only one share you check your user permissions for each share

maybe a screen shot of your storage settings too.