Roon Ready endpoint (Bricasti M3) disappears in Roon [faulty cable]

My set up:

  • Core: Roon Nucleus+
  • End point: Bricasti M3h
  • Netowrk connection: LAN (1gb fast speed)

My problem:

I just got a brand new Bricasti M3 with Roon-Ready network card.

I’ve set it up through LAN connection (I’m using a Nucleus+ server in remote location) and it showed as a Roon Ready audio zone and I’ve listened to it for an hour or so. But then the zone disppears. It’s been popping occasionally and then disappearing. I can’t get it to show in the Audio zones any more.

I tried hard reboots across the board (of the Nucleus+ core, of the Bricasti component, of my computer). I also checked this phenomenon appears across roon players on various devides (it does, on both my Windows PC and iPhone app). And I’ve confirmed the Bricasti, which is brand new, works well - I can play to it from Roon via a USB from my local PC.

What is causing this unstable connection to a Roon Ready device? and how do I get it to appears in my audio zones?!?

Thanks for any urgent help!


In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

I just updated above, can you please assist?

Hi Eyal,

By networking information, the network chain should be detailed, like the Make model of Switches, or routers in the stream.

You might try changing the Network cable TO the BRicasti, first. And, then change the port on the switch the Bricasti is plugged into. As a cable or port on the switch could be flaky.



The router is PAKEDGE RK-1 which is connected via LAN to the Bricasti

I’ll try a new cable, however this cable worked seamlessly with the Mytek Brooklyn Bridge that was using exactly the same cable and connection until two days ago, making this highly unlikely to be the issue

Power cycle the whole network starting from the router.

1 Like

Thank you.

I am following all your suggestions and trying to narrow down which element is causing the issue - will report back

@Rugby - in the end you were right and it was a faulty cable… problem solved!

Thanks so much everyone


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.