Roon Remote & Arc not fully loading from core

Roon Core Machine

Late 2015 27" iMac, 3.4Ghz i5, 24 GB Ram

Networking Gear & Setup Details

Core wired directly to 5G router. Remotes are connected via wifi or ethernet.

Connected Audio Devices

Various - Arc on iphone 14 Pro Max on wifi or 5G / Macbook air on wifi / Macbook pro on Ethernet / RopieeXL on Ethernet.

Number of Tracks in Library

10,648

Description of Issue

Not really sure how to properly describe this issue - after a period of time my remotes seem to have a problem fully loading from the core. If using a Roon remote then the UI loads and seems to connect to the core but then I just get the Roon logo instead of any content loading (see screenshot). On Arc I just get a ‘poor connection’ and can’t play anything.

iMac is not sleeping and network conneciton to it is fine. If I remote onto the iMac then it’s working fine and Roon Server is running. If i quit the server then the remotes then see that and show that they have lost connection to the core. After a restart of the server app on the iMac it’s working again.

Note that I already tried uninstalling the Roon app from the imac, including renaming the database folders and then reinstalling.

Update on this - it seems to be Arc that is causing the issue. I can listen via Roon clients with no problem but the last three times I’ve used Arc to stream it will play a few songs and then stop in between songs. I then get a ‘Poor connection’ message on Arc and all my Roon remotes then have the behaviour I reported above. Only fix is to restart the Roon Server app.

iMac and network remain fine throughout all of this.

Can I get some help with this please Support?

Sam behaviour today trying to use Arc at the office, three tracks in and it stopped as above. I’d tried deleting and re-installing the app on my iPhone.

Support??? Any help?

Hi @Kevin_O_Brien,

Thank you for your report and for your patience as we worked through the queue to investigate diagnostics on your account.

An initial pass through Core logs reveals numerous UPnP connectivity errors; these can lead to port forwarding failures (ARC), as well as endpoint dropouts in Roon Remote. Do you have the latest firmware installed on your routers? Usually, this will guarantee you don’t have an expired UPnP protocol in place.

There are also network errors attempting to reach Roon’s servers during routine operation of RoonServer. We’ll want to verify there’s not a local network problem here.

What is the make/model of your modem and router?

Do you have any VPNs, proxy servers, or firewalls in place on your Core or router(s)? Have you recently migrated RoonServer between devices?

We’ll investigate further once we know a little more.

Thanks Connor.

Yes, I’m on the latest firmware of the router but I believe an update is currently rolling out for the device.

I am using a Three branded Zyxel NR5103E router. No VPN’s/Proxies or firewalls in place.

I did migrate the core from a NUC, restoring from a backup.

I’ve got another broadband network in the house (Virgin Media Fibre) so I can switch to that for further testing, but I don’t want to run on that long term as its frankly terribly unreliable.

I’d also point you to another Support thread with the same/similar symptoms. We both seem to be running on Three 5G internet:

1 Like

Thanks, @Kevin_O_Brien. I’m working directly with my teammate @benjamin who is monitoring that thread, so updates in either thread will reach the entire technical support team. We’ll have another look at the most recent diagnostics; if you don’t mind, please leave Roon running on any affected device for at least one hour during the next day so our servers have a chance to reach logging.

Will do, thanks.

Quick update - I moved my core over to a new NUC and the issue still remains. So it’s not the iMac at least.

I’d switched to the latest early access builds before using Arc today and did still have the issue.

1 Like

Still having this issue all the time. Arc is just not usable for me like this.

This week I travelled and used Arc in offline mode. As soon as I came home and was on Wifi I turned Arc back to online mode to sync my play history and immediately the core hung as per above (and other user reports) and I had to restart the core to get it working again.

Hi @Kevin_O_Brien,

An unacceptable amount of time has passed, perhaps rendering this troubleshooting suggestion extraneous. The tech support team would like to apologize.

Are you still having issues with Remote and ARC sync? We’ve resolved a variety of issues that were underpinning “Poor Connection” errors in ARC around the time of your report. Similarly, the most recent releases of Roon 2.0 contained a variety of stability fixes that ought to have improved these symptoms on most networks that were reporting them.

If you’re still having connectivity trouble, let us know, and we’ll promptly pull diagnostics and provide next steps. In the meantime, you can try a database refresh to erase any obsolete cached data that is interfering with Roon:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

We’ll be watching for your response and you can expect a far more acceptable response time.

Hi,

I’d mostly stopped trying with it to be honest. I am travelling for work over the next two days, so I will try it and see if I still have the same problems.

Cheers,

Kevin

@Connor I tried it out again this week and have the same issue.

Monday night I updated Arc on TestFlight and played a few songs on my wifi with no issues.
Tuesday morning I left the house to travel for a few days and Arc would not connect to my core.
Last night I came home and I cannot load Roon on any device, I get the exact same behaviour as mention in my original post.

As of right now I have not restarted the core in case you need any logs.

1 Like

Hi @Kevin_O_Brien,

Thank you for the update. We’re pulling diagnostics now and I’ll sync with our team briefly before circling back.

@Connor - Any progress?