Roon remote back button and false focus setting

Windows headless server hardwired to router and dac; Roon remote via WiFi.

For a while now, I have had an issue with my two Android Roon remote devices: I select an album via album view, start playing it, minimise the app, and when the music has finished, I reopen the app but get a blank screen. The back button does nothing, and selecting album view again gives me a blank screen, with an error message saying remove some focus criteria - but I have not used any focus criteria.

I thought this issue was unique to Android, because I hadn’t experienced the problem from the Roon remote app on my desktop windows machine, but a few days ago, I got the exact same issue on that device as well.

It’s all very frustrating, because I have to close Roon down and relaunch it every time I want to play more music.

Is this a known issue?

Hi @Vaughan_Barnacle,

The next time you notice this, can you share a screenshot of what you’re seeing and provide the time that you noticed it so we can take a look?



Two screenshots to follow: one of the blank screen that doesn’t respond to the back button, and one of the empty album view when I went into it immediately afterwards. (Time shown in top left-hand corner.)

Thanks, @Vaughan_Barnacle.

I’ve enabled diagnostics on your account. Once the diagnostics report comes in I’ll pass it along to the team for review. Can you confirm what type of Android device you’re using as your remote here?

I have a Samsung Galaxy S9. (The problem also occurs on a Galaxy tablet, and on a windows 10 desktop.)

Thanks @Vaughan_Barnacle — I’ve passed the diagnostics report along to the team as well as the information provided here. I’ll be sure to follow up once I’ve received their feedback on this.

Hello @Vaughan_Barnacle,

I appreciate your patience while the technical team reviewed diagnostics information.

They have noted that you appear to be running Roon on an under-spec’d machine, which may be partly the cause of this issue.

If you run Roon on a machine that meets our Minimum Requirements, can you please confirm if you are able to see the same behavior?

Hi. It seems unlikely that the spec of the machine running Roon core is at fault. The issue I have been experiencing is far more common on Android remotes, and has only happened twice on my desktop computer (which I use most often). If it were the core at fault, then wouldn’t I have the issue regularly on all remote devices? I can’t run the Roon core on another machine, so I am unable to see if that would help. As an aside, the Nimitra server that I have been using has never had any issues running Roon, and can even cope with full up scaling.

Hi @Vaughan_Barnacle,

Can you please try to temporarily host the Roon core on your Windows 10 Desktop and let me know if you still experience similar behavior? I would first create a Backup of your current Roon database and then open Roon on the Windows desktop and navigate to Settings -> General and press Disconnect.

Then instead of selecting the Nimitra as the Core, please select Use this PC. Once the Desktop is acting as the Core please let me know if you experience the same issue on your remotes. Thanks!

I don’t see how I could do that: the desktop is two rooms away from the music system and wouldn’t be able to connect to my non-networked dac.

Hi @Vaughan_Barnacle,

I would only be asking you to host the Roon Core on the Windows 10 desktop. You can still leave an instance of Roon Bridge running on the headless server and then with Roon Bridge you should still be able to access the audio outputs via the network.

As you’ve probably realised, I’m no IT expert. I have never even heard of Roon Bridge. I’m worried about messing up my hi-fi chain. The Nimitra is not user-accessible, so any adverse changes will be permanently bad. I keep applying logic to this issue, and finding it hard to imagine it’s the core at fault. If I click on album view, it’s there immediately. Why should it fail to re-establish that position? Have you even tried to recreate this issue on your Android test machines?

Hi @Vaughan_Barnacle,

We have tried to reproduce this behavior on our end, but we are not seeing it happen. If this was a wide-spread issue, we would have surely had more than this one report, so something in your setup may be different when compared with other Roon setups.

Moving forward, I would like to take a look at the network in case this is impacting this issue. Can you please let me know the model/manufacturer of all your networking gear and how the Core and Roon Remotes are connected here? Have you previously tried connecting the Windows 10 Remote via Ethernet?

I’m using a Synology RT1900ac router, with the Nimitra core directly connected by ethernet. The Nimtra connects by usb cable to an RME ADI-2 Dac, which connects via rca cable to my amplifier. The Roon remotes are all wireless via the private home network. The desktop is about 15 metres from the rest of my network/audio gear, so no, I haven’t tried connecting via ethernet.

Hi @Vaughan_Barnacle,

Thanks for letting me know that information. I have been discussing your case further with the technical team and have since enabled diagnostics mode for your account, and what this action does is upload a set of logs to our servers for review.

I asked the technical team to review the logs, and from what we can tell your Android device dropped from the network at the time you reported the issue (August 20, 21:45) and triggered the behavior you observed, indicating that something is not stable on the network side of things.

I have two follow-up questions/suggestions:

  1. I would try connecting the Core via Ethernet if at all possible (either by using a long Ethernet cable as Ethernet is rated up to 100 meters, or by using a mesh-style network such as Orbi/Eero/Velop).

  2. If you try pressing the main menu (“hamburger”) icon when this issue occurs and trying to go back to the overview or discover area, does this help re-establish the connection?


As I mentioned in my previous post, the core IS connected by ethernet - always has been. (A 1 metre cable.)

I can use the hamburger button to access other Roon menus after this issue occurs, just can’t use the back button on the Android devices, or return to Album view (which is how I select most of my music). If I selected music in another way, different issues may arise - or not…

8 posts were split to a new topic: Roon Radio Turns On by Itself

Hi @Vaughan_Barnacle,

Can you please let me know the approximate next time you notice this behavior? Do you have any other devices that can start Roon playback such as a Logitech Harmony Hub or other type of IR blaster/remote?