Roon remote back button and false focus setting

Hello @Vaughan_Barnacle,

I appreciate your patience while the technical team reviewed diagnostics information.

They have noted that you appear to be running Roon on an under-spec’d machine, which may be partly the cause of this issue.

If you run Roon on a machine that meets our Minimum Requirements, can you please confirm if you are able to see the same behavior?

Hi. It seems unlikely that the spec of the machine running Roon core is at fault. The issue I have been experiencing is far more common on Android remotes, and has only happened twice on my desktop computer (which I use most often). If it were the core at fault, then wouldn’t I have the issue regularly on all remote devices? I can’t run the Roon core on another machine, so I am unable to see if that would help. As an aside, the Nimitra server that I have been using has never had any issues running Roon, and can even cope with full up scaling.

Hi @Vaughan_Barnacle,

Can you please try to temporarily host the Roon core on your Windows 10 Desktop and let me know if you still experience similar behavior? I would first create a Backup of your current Roon database and then open Roon on the Windows desktop and navigate to Settings -> General and press Disconnect.

Then instead of selecting the Nimitra as the Core, please select Use this PC. Once the Desktop is acting as the Core please let me know if you experience the same issue on your remotes. Thanks!

I don’t see how I could do that: the desktop is two rooms away from the music system and wouldn’t be able to connect to my non-networked dac.

Hi @Vaughan_Barnacle,

I would only be asking you to host the Roon Core on the Windows 10 desktop. You can still leave an instance of Roon Bridge running on the headless server and then with Roon Bridge you should still be able to access the audio outputs via the network.

As you’ve probably realised, I’m no IT expert. I have never even heard of Roon Bridge. I’m worried about messing up my hi-fi chain. The Nimitra is not user-accessible, so any adverse changes will be permanently bad. I keep applying logic to this issue, and finding it hard to imagine it’s the core at fault. If I click on album view, it’s there immediately. Why should it fail to re-establish that position? Have you even tried to recreate this issue on your Android test machines?

Hi @Vaughan_Barnacle,

We have tried to reproduce this behavior on our end, but we are not seeing it happen. If this was a wide-spread issue, we would have surely had more than this one report, so something in your setup may be different when compared with other Roon setups.

Moving forward, I would like to take a look at the network in case this is impacting this issue. Can you please let me know the model/manufacturer of all your networking gear and how the Core and Roon Remotes are connected here? Have you previously tried connecting the Windows 10 Remote via Ethernet?

I’m using a Synology RT1900ac router, with the Nimitra core directly connected by ethernet. The Nimtra connects by usb cable to an RME ADI-2 Dac, which connects via rca cable to my amplifier. The Roon remotes are all wireless via the private home network. The desktop is about 15 metres from the rest of my network/audio gear, so no, I haven’t tried connecting via ethernet.

Hi @Vaughan_Barnacle,

Thanks for letting me know that information. I have been discussing your case further with the technical team and have since enabled diagnostics mode for your account, and what this action does is upload a set of logs to our servers for review.

I asked the technical team to review the logs, and from what we can tell your Android device dropped from the network at the time you reported the issue (August 20, 21:45) and triggered the behavior you observed, indicating that something is not stable on the network side of things.

I have two follow-up questions/suggestions:

  1. I would try connecting the Core via Ethernet if at all possible (either by using a long Ethernet cable as Ethernet is rated up to 100 meters, or by using a mesh-style network such as Orbi/Eero/Velop).

  2. If you try pressing the main menu (“hamburger”) icon when this issue occurs and trying to go back to the overview or discover area, does this help re-establish the connection?


As I mentioned in my previous post, the core IS connected by ethernet - always has been. (A 1 metre cable.)

I can use the hamburger button to access other Roon menus after this issue occurs, just can’t use the back button on the Android devices, or return to Album view (which is how I select most of my music). If I selected music in another way, different issues may arise - or not…

8 posts were split to a new topic: Roon Radio Turns On by Itself

Hi @Vaughan_Barnacle,

Can you please let me know the approximate next time you notice this behavior? Do you have any other devices that can start Roon playback such as a Logitech Harmony Hub or other type of IR blaster/remote?

Weirdly, the issue hasn’t resurfaced, but the back button / album view / focus issue remains. And no, I don’t have any other devices that could be controlling Roon.

Hi @Vaughan_Barnacle,

I spoke to the technical team again regarding your issue and they have let me know that this is likely either a Networking or a Core issue. There are two ways we can proceed here:

A. We try to host the Roon Core on a properly spec’d machine such as your Windows PC currently running as a Roon Remote

B. We try a different network setup that temporarily replaced the Synology router with another standard consumer-grade router.

In my opinion, option one would be the simplest to test and wouldn’t require any new gear to be purchased, and you can still keep your devices connected in the same way. What I suggest is the following:

  1. Open Roon and create a Backup of your current database
  2. Navigate to Roon Settings -> General and press “Disconnect”
  3. On the “Choose your Core” screen, press “Use this PC”
  4. Enable the Audio device connected your your Nimitra in Roon Settings -> Audio
  5. On your Android Remote, select the Windows PC as the Core instead of the Nimitra
  6. Use this setup for a day or two

If you configure the system in the above way, do you still experience the behavior with the Android remote?

Hi @Vaughan_Barnacle,

Thanks for letting me know that timestamp, I can confirm logs have been received and I have forwarded them to QA for a closer look, I will let you know once I have further feedback from them.

Apologies if this is not clear, but you can use your Nimitra as a Roon Bridge while hosting the Roon Core on the PC. You won’t need to reconfigure any of the connections, the DAC can still stay attached to the Nimitra Core as it currently is connected.

Once you perform my above instructions, the Nimitra Core will turn into a Roon Bridge device and you will be able to select your currently connected DAC to the Nimitra in Roon Settings -> Audio and play to it, again without changing any of the physical connections.

The Core would be facilitating the audio processing but the Nimitra would still be outputting to the DAC. Hopefully this clears up the request a bit.

So I have tried running Roon Core on my desktop PC, and I still have exactly the same issue. I uninstalled the Roon app on my Android devices, and reinstalled them, in case that would help; it didn’t. Interestingly, when I reinstalled the app on my Android tablet, there was a warning saying that the app is not optimised for my device - that certainly seems to be the case. (Didn’t get that warning with my Samsung Galaxy S9.)

Hi @Vaughan_Barnacle.

@noris is currently out of town but I can help while he’s away.

Thanks for giving this a try with a different Core! We’d like to enable some diagnostics so we can compare what was happening on the Nimitra Core and this Desktop PC Core. Can you reproduce this issue once more with the desktop Core and make a note of the time it happens? From there we will enable the diagnostics so the team can take a look.

I don’t see the point of running diagnostics on the windows core, if running it on the Nimitra showed nothing. Has to be a software incompatibility with the Android devices. Thing is, I’m running pretty up-to-date Android devices. Not very encouraging. I wish Roon would spend as much time making their software work reliably as they spend upgrading it. Seems the design team are writing cheques the technical team can’t cash.

Hi @Vaughan_Barnacle,

No necessarily. The original thinking here was to use Roon on a properly spec’d Core to get this aspect out of the way.

If you wish to work with us, we can take a closer look at this behavior. We don’t have many different types of Android remotes in-house for testing, but if logs display anything actionable towards this issue, we can take a look and file a bug report, but first we have to prove that this is an actual bug.

If you’d like to continue with troubleshooting, please provide the information that @dylan requested above, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.