Roon remote back button and false focus setting

Weirdly, the issue hasn’t resurfaced, but the back button / album view / focus issue remains. And no, I don’t have any other devices that could be controlling Roon.

Hi @Vaughan_Barnacle,

I spoke to the technical team again regarding your issue and they have let me know that this is likely either a Networking or a Core issue. There are two ways we can proceed here:

A. We try to host the Roon Core on a properly spec’d machine such as your Windows PC currently running as a Roon Remote

B. We try a different network setup that temporarily replaced the Synology router with another standard consumer-grade router.

In my opinion, option one would be the simplest to test and wouldn’t require any new gear to be purchased, and you can still keep your devices connected in the same way. What I suggest is the following:

  1. Open Roon and create a Backup of your current database
  2. Navigate to Roon Settings -> General and press “Disconnect”
  3. On the “Choose your Core” screen, press “Use this PC”
  4. Enable the Audio device connected your your Nimitra in Roon Settings -> Audio
  5. On your Android Remote, select the Windows PC as the Core instead of the Nimitra
  6. Use this setup for a day or two

If you configure the system in the above way, do you still experience the behavior with the Android remote?

Hi @Vaughan_Barnacle,

Thanks for letting me know that timestamp, I can confirm logs have been received and I have forwarded them to QA for a closer look, I will let you know once I have further feedback from them.

Apologies if this is not clear, but you can use your Nimitra as a Roon Bridge while hosting the Roon Core on the PC. You won’t need to reconfigure any of the connections, the DAC can still stay attached to the Nimitra Core as it currently is connected.

Once you perform my above instructions, the Nimitra Core will turn into a Roon Bridge device and you will be able to select your currently connected DAC to the Nimitra in Roon Settings -> Audio and play to it, again without changing any of the physical connections.

The Core would be facilitating the audio processing but the Nimitra would still be outputting to the DAC. Hopefully this clears up the request a bit.

So I have tried running Roon Core on my desktop PC, and I still have exactly the same issue. I uninstalled the Roon app on my Android devices, and reinstalled them, in case that would help; it didn’t. Interestingly, when I reinstalled the app on my Android tablet, there was a warning saying that the app is not optimised for my device - that certainly seems to be the case. (Didn’t get that warning with my Samsung Galaxy S9.)

Hi @Vaughan_Barnacle.

@noris is currently out of town but I can help while he’s away.

Thanks for giving this a try with a different Core! We’d like to enable some diagnostics so we can compare what was happening on the Nimitra Core and this Desktop PC Core. Can you reproduce this issue once more with the desktop Core and make a note of the time it happens? From there we will enable the diagnostics so the team can take a look.

I don’t see the point of running diagnostics on the windows core, if running it on the Nimitra showed nothing. Has to be a software incompatibility with the Android devices. Thing is, I’m running pretty up-to-date Android devices. Not very encouraging. I wish Roon would spend as much time making their software work reliably as they spend upgrading it. Seems the design team are writing cheques the technical team can’t cash.

Hi @Vaughan_Barnacle,

No necessarily. The original thinking here was to use Roon on a properly spec’d Core to get this aspect out of the way.

If you wish to work with us, we can take a closer look at this behavior. We don’t have many different types of Android remotes in-house for testing, but if logs display anything actionable towards this issue, we can take a look and file a bug report, but first we have to prove that this is an actual bug.

If you’d like to continue with troubleshooting, please provide the information that @dylan requested above, thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.