Roon Remote Can't Connect from iPhone or iPad

Core Machine (Operating system/System info/Roon build number)
iMac, OS Big Sur 11.2.3/Roon 1.8 Build 756

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity Gateway Router with Ethernet connection (and a home Wi-Fi setup)
Also 2 ZyXEL EoP devices

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio DirectStream DAC connected via Ethernet

I’ve had the same basic setup (including EoP devices) since I first purchased Roon well over a year ago. Originally remote operation from iPhone or iPad was fine. After several months it became spottier but now it does not connect at all.

Only real system change has been upgrading to Mac iOS Big Sur.

I’ve tried all the trouble shooting instructions I found on Roon. I noticed two possible problems:

  1. The IP address and network settings differ from the iMac to the iPhone. So I changed to manual settings on the iPhone and typed in and saved the identical settings from the iMac. I then could not connect to the internet at all on the iPhone. So I went back to the automatic settings on the iPhone.

  2. I tried to reconfigure the Core on the iMac. But clicking on the “Configure” button doesn’t do anything. It says it is trying but it never succeeds.

Thoughts? Help?? Thanks.

Hello @Geoff_Mirelowitz,

A) Can you describe what you are seeing in the iOS application when you open it? It would be helpful if you could attach a screenshot to the post so that we know what we’re looking at. You can attach a photo by clicking on the “landscape” photo when you open the textbox for a reply.

B) Check your firewall settings in System Preferences > Security & Privacy > Firewall. To start I would ensure that the firewall is enabled to rule it out as a factor. If that turns out to be the culprit you can add exceptions for and


Thanks John. I did check the Firewall settings and there is an exception for Roon. But just for good measure I turned the Firewall off and tried Roon remote again. No change.

Here’s the screenshot:

I did everything those instructions said to do.

Hello @Geoff_Mirelowitz,

What happens when you tap the “Select a different core” button?


If you want me to choose “Yes” I can give it a try. Not sure what the result would be so I chose “no.”

I should have mentioned that – due to a completely separate issue – I did the reinstall the Mac OS with an Apple Senior Advisor on the phone with me. We did use Time Machine to do the reinstall.

I then reinstalled Roon (per advice from Roon Support @dylan) successfully about 3 weeks ago. Remote has not worked at all since then (it was seriously spotty even before that).

Apologies for not reporting this at the outset.

Your core is not updated, suggest you get on to V764, and also check your iOS devices have the latest apps build too.

Thanks. I wish I understood how to do what you’ve suggested. @john perhaps you can explain more?

I believe I have updated the iOS device apps (though I don’t know the term “build top” or how to check that).

I was not aware there was any way to “update” a Core, separate from updating the version of Roon I am using. And as I said I recently reinstalled Roon on my iMac (where the Core resides) following both my own update to Mac OS 11.2.3 and following the release of the latest version of Roon.

Sorry corrected to too.

When you say reinstalled how did you do this…not from time machine I hope, as this will totally mess things up.

You can go into settings and about to check the Version of roon on the Mac and should be able to update from there too if one is available.

Yes, I used Time Machine as I explained above. I had no idea that would affect Roon. But that is why — as I also explained — I reinstalled Roon as I was told to do by Roon support.

Also as I explained, I have the latest version of Roon installed. If there is some separate process to update the Core, I don’t know what that is.

@john: One more piece of information that may or may not be relevant:

When I try to control Roon remotely from my iPhone or iPad, it is not simply that it doesn’t work. It generally results in what has been trouble free play (controlled from my iMac where the Core resides) either leading to dropouts, to skipping songs in the queue (with various explanations) and most often play stopping altogether.

I can usually fix that by getting up and controlling play again from the iMac.

@support can I expect any further help with this issue? I hope so.

Hey @Geoff_Mirelowitz,

Thank you for trying all the troubleshooting steps that you have - I’m only sorry they didn’t seem to work.

I’m sorry for the delay in getting back to you - it is because support is open Monday through Friday.

If I haven’t missed anything, it looks like you didn’t try reinstalling the Roon Remote app on your remote devices. Could you please try deleting the app and reinstalling it?

Thanks in advance :pray:

Rebecca thank you!!! That did it!

I had thought it sufficient to simply make sure the old version was up to date. But when I deleted the old app and reinstalled the new one I learned it has a different name. Although the icon on my iPhone is the same, the app (when searched for in the App Store) is now called “Roon Remote” – as you indicated in your note.

Crossing my fingers this solves the problem. So far so good.

1 Like

Wow! Thank you for trying that @Geoff_Mirelowitz! I couldn’t be happier that it worked. I hope it’s a permanent victory :muscle:.

Please, do keep me posted if the issue returns.

Enjoy the music :musical_note:

1 Like

I will certainly do that. Thanks again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.