Roon Remote can't See CoreAudio on Mac

HAPPY WEEKEND, Roonoids and Roonettes! May I beg some help?

I’ve got a 2014 Mac Mini running OS-X Catalina. Roon’s installed there with an external USB HDD providing data storage. Control is via an iPad with Roon Remote.

I previously had my Black Ice Audio DAC connected to the Mini via USB, but kept getting audio playback dropouts despite having increased the buffering cache. So I switched the audio output to optical TOSLINK.

The SOUND panel on the Mini sees (and is set to) Optical Output. The Roon on the Mini doesn’t identify the Black Ice DAC (like it did when the USB connection was used) but with CoreAudio enabled (and System disabled), I can play anything in my library from Roon through the TOSLINK output with no issue.

But when I try to control this through Roon Remote, I get the message that no Audio Device is selected. I look at the options, and enable CoreAudio, but the Roon Remote ignores the selection, telling me that no Audio Device is selected. I’ve tried enabling System Audio only, CoreAudio only, and both at the same time. Same result.

The Roon Remote program IS connecting with the Roon install on the Mac Mini - they just won’t tango together. So far, I’ve rebooted the Mini twice, rebooted the iPad twice, and gone through MIDI settings and Security settings. Nothing looks wrong. The only thing left that I can think to try is to delete the server from Roon Remote, and then let it connect again from scratch.

So my question is “why can’t I use Roon Remote with the TOSLINK output of the Mac Mini?”

Thanks, y’all & have a great weekend!


Update - I deleted Roon Remote from my iPad, downloaded it again, reconnected to the Mac Mini - And now the iPad can’t see ANY of the zones on the Mac Mini - only the iPad itself. Going backwards here… But I do know that the Roon Remote IS connected to the Mac Mini because I can play any of the tracks in Roon (hosted on the Mini) through the iPad speakers.

It would be better if you posted in the support category of the forum as that is monitored more.

Hi @ged_hickman1 -

THANK YOU for moving the question. I still haven’t solved the problem. In fact, I just went back to JRiver Media Center until I can get Roon working again.

JRiver works perfectly with everything as it is and sounds pretty good doing it. But Roon Remote STILL won’t admit that there’s an audio device there. Any ideas?

Thanks - Boomzilla

1 Like

A room remote is only a view and control for the server it is attached to. On an iPad when you go to audio devices you are seeing what the server sees, the remote doesn’t see anything, even it’s own local audio devices.

It might be beneficial to post some screen shots showing the same screen on each device

1 Like

You got drop outs when connected via USB? Shouldn’t be, so that in itself is troubling.
The USB connection might not have been the problem.

Yes, I’ve noticed that with Toslink connections from my RPi HAT. So, probably nothing unusual there.

Hi @Rugby -

I understand what you’re saying, but that’s NOT what’s happening on my system. The server sees more, and the iPad Roon Remote DOES see the iPad as a destination. I’ll post screen shots this evening.

Hi @xxx -

First, thanks for confirmation that Roon doesn’t usually see the DAC from the server if connected by TOSLINK. That’s one worry I need not be concerned with.

Second, you’re entirely right that there SHOULD not be dropouts regardless of the output method. I’ve increased the cache on the computer, the cache in Roon, and used a different external HDD (and different USB-3 cable). None had any effect. Any other ideas?

Just some questions that probably won’t help because they’re mostly related to the drop out problem.
It’s really confounding to have your kind of problem with a Remote.

My WIN10 RoonServer==>Ethernet connected RPi endpoint sends it’s stream to my DAC via Toslink and I have no problem with any Remote, iOS or WIN10.

Drop outs occur when playing local, streaming or both?

If streaming then Core is connected how? Wifi or Ethernet.

Usually drop outs ae a network problem and shouldn’t happen with a USB connection to Core.

Are you saying that with your DAC connected by Toslink that you have no dropouts?
I keep harping on this because I’m not convinced that the dropout problem will be resolved regardless of how the Remote problem is addressed.

BTW - I used to use a 2014 Mini to run Core. I hated the :poop:, but I guess that doesn’t help. :neutral_face:

You might like to fill in the info needed below before someone asks for it again anyway.

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


1 Like

OK - So this thread is splitting into two different issues:

  1. Inability of Roon Remote to see and use the TOSLINK output of my Mac Mini

  2. Presence of noise and dropouts on the USB output to my DAC

Let’s dispense with number one now. As @xxx pointed out, the TOSLINK connection, unlike the USB one, is not bi-directional. Thus, Roon Remote can’t tell that there’s a DAC there. I tried to “identify” the DAC through Roon, but apparently the TOSLINK connection to the Black Ice DAC is not in Roon’s “approved device” list (although it is identified in the USB connection just fine). Until Black Ice Audio and Roon decide to update their approved device list to include the TOSLINK capabilities of the DAC, I’ll never be able to use the TOSLINK port from Roon Remote. Discussion completed - period. This isn’t currently fixable without modification of the Roon software.

Now to problem 2 - This becomes FAR more important if it is the only interface I can use between Roon and the DAC. I’ll provide the information requested by @wizardofoz later this morning.

Thanks again for the help - I appreciate it GREATLY!

Hmm, I don’t think that’s the case.

The fact that you can play to the Toslink’ed DAC from the Mini means that Roon ‘accepts’ it as a valid device. Not being an ‘approved’ device doesn’t necessarily mean Roon can’t see it, as this case shows.

It occurs to me, after re-reading your posts, that we might have a mis-communication about what Remote means. Sometimes, it seems that when you say Remote, you really mean endpoint. Without insulting your experience, Remote is simply a device used to control Roon and endpoint is a device to accept a stream from Core and pass that stream to a DAC, briefly speaking. That’s how you’re using the terms, right?

See the problem is that a Remote is just reporting/controling the Core’s configuration. Since the Core can see and play to your Toslink’ed DAC, it doesn’t make any sense (if we are talking about Remote in the same way) that your Remote can’t see it.


Agree completely, but only because if there’s a problem with USB there will probably be a problem with Toslink.


Late 2014 Mac Mini
2.6 GHz. I5 / 2-Core
OWC Aura Pro SSD Drive - 250 GB capacity / 240 GB free
OS-X 10.16.6 (Catalina)


Roon 1.7, Build 571
Audio Devices (This Mac):
System Output (disabled)
Built-In Output (disabled)
HDMI CoreAudio (disabled)
Black Ice USB Audio CoreAudio (enabled)

On the Roon Remote installation of the iPad, all of the above show up in addition to "This iPad) as devices, and the Black Ice USB is selected - but NOW the Roon Remote won’t recognize the CoreAudio Black ice either (and so nothing can be played from Roon Remote).

I’ll be honest - I’m getting REALLY frustrated here. I’m probably doing something stupid, but I can’t discern what it might be.

If your DAC is connected by Toslink (or USB for that matter) to your Mini then in the iPad Remote it should show up under the heading ‘Connected to Core’.

I don’t understand this statement. Is the DAC connected to your Mini or to the iPad?

Maybe the Remote on your iPad is out of date?
What does Settings==>About look like?

Hi @xxx -

My DAC IS connected (now) back to USB. Yet NOTHING is showing on the Mac Mini as “connected to core.” Yet the Roon program on the Mini can play anything in the Roon library via the USB output.

The Roon Remote on the iPad now sees nothing except those Roon options listed in my previous email plus “this iPad.” But if I select “this iPad,” I can access anything in the Roon library from the remote iPad software, and play it on the iPad speakers.

But Roon Remote on the iPad does NOT play through the DAC connected to the Mac Mini. No way, no how.

And this is where the confusion lies if you expect the DAC that is connected to the Mini to play to the iPad.

It doesn’t work that way.


This is because mobile remotes like phones and tablets are considered Private Zones and normally hidden from other control points unless the Private Zone switch under device settings is set to OFF.

See this FAQ for more details.

If you turn Private zones to off, then you will see the tablet listed under devices in the Mac Mini. It also might be the reason that any device connected TO the iPad is also not registering with the Server.

NO - confusion here - I am NOT asking anything to play to the iPad. I’m trying to get Roon to play through the Black Ice DAC connected to the Mac Mini. It will do so when selecting music from the Mac Mini, but the Roon Remote app on the iPad can no longer control playback through the Mini’s DAC.

Thanks - I do understand the difference between “Remote” (the Roon Remote app on the iPad) and “endpoint” (the Black Ice DAC connected to the Mac Mini). I’m using the terms as clearly as I can. Let me summarize again to avoid further confusion:

Using EITHER the USB or the TOSLINK connection, I can play music from Roon through the endpoint DAC from the Mac Mini where Roon is installed.

Regardless of connection, I can no longer play music from Roon through the endpoint DAC when controlled by the Roon Remote app on my iPad. Despite this, the iPad CAN play through its own speakers from Roon if I select the iPad as the endpoint. This proves beyond any doubt that the wireless connection is robust, working properly, and that the Roon Remote app CAN see the Roon program on the Mac Mini.

OK, see what confuses me is what the Remote is just mirroring what the Core knows about and the Core knows about your DAC because you can play to it from there.

Did what @rugby post make a difference?

I’m out of ideas. Good luck.