Roon Remote connection failed TP-Link Deco M4

Core Machine (Operating system/System info/Roon build number)

Device: Lenovo T480 laptop
OS: Windows 10

Device: iPhone SE2020
OS: 14.0.1

Roon build number: v1.7(610) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Networking gear: TP-Link Deco M4 (1 main router and 2 access points for mesh WiFi). Main router is connected to Ziggo Connect box modem which is in bridge mode.
Laptop is connect via WiFi but also tried Ethernet (does not make any difference).
Iphone SE2020 is connect via WiFi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Denon PMA-A110 via USB-DAC

Description Of Issue

Dear sir/madam,

I am enjoying Roon now for a while. But unfortunately a problem occurred after the installation of my new TP-Link Deco M4 mesh WiFi network system.

At the moment the Roon Remote app on my iPhone SE2020 cannot make a connection with my Roon Core device (Lenovo T480 laptop).

Hope you can help me out.

Kind regards,

Thanks for your support Peter.

I tried this setting now and rebooted all my network gear. But problem is still here. Hope there is another solution.

In a network, there should be exactly one (and no more) router providing DHCP server. Typically a user already has a functioning router, and buys a WiFi solution to enhance the WiFi coverage. This is why I suggest keeping the original router functionality, and turn the new WiFi system into bridge (AP) mode.

The remaining thing is that the WiFi needs to pass the multicast packets as required by Roon. This is often bound to some sort of IGMP setting. Please find and experiment with your WiFi IGMP / multicast settings.

Try to switch your Deco system from access point mode into router mode. This should be the default mode, as your modem is in bridge mode.
Go to the Deco app, go to advanced settings, then to operating mode and switch to router mode. The Decos will reboot aftter this.
If it doesn’t work, you can always switch back.

On another forum, a user with TP-Link Deco X60 just ran into the same problem and solved it by using AP mode, while keeping his separate main router unchanged.

Another user got a working setup with TP-Link Deco M9 Plus in router mode.

So you’ll need to experiment with different possible setups and see which work for you.

Hi @Dennis_van_Berlo,

If you temporarily unplug the two mesh nodes, are you able to connect?
If sounds like you have multiple subnets set up with the additional nodes.
Please see our Networking Best Practices Guide for more networking info.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.