Roon Remote crashes after selecting "disable multi-part composition" for a specific album [Ticket In]

Roon Core Machine

Mac Mini (late 2014), 3 GHz Core i7, 16 GiB RAM, OS X 10.12.6 Sierra

Networking Gear & Setup Details

Fritz!Box 7530

Connected Audio Devices

Devialet 1000 Pro, wired Ethernet to core

Number of Tracks in Library

20,000+ tracks

Description of Issue


Roon Core and Roon Remote are up to date (build 884).

I’m running Roon Remote on several devices including a Mac (macOS 10.15.7 Catalina), an Android pad and an iPhone.

I was listening to an album and used Roon Remote to edit the album to disable multi-part grouping, as it was mangling the track titles. If it matters, the album in question was Carlos Seixas - Sonatas by Rebeca Oliveira (on Qobuz). As soon as I made that selection, Roon Remote exited on the Mac.

If I try to start Roon Remote again on the Mac, it exits immediately.

Furthermore, Roon Remote on the Android device, which happened to have the same audio zone selected, will no longer connect to the core (I just see the pulsating Roon logo on a white background - there’s no text or core selection option).

I tried stopping and re-starting the Core, but this hasn’t changed the behaviour.

Fortunately, I was able to use Roon Remote on the iPhone to connect to the core and clear the queue, after which Roon Remote on the Mac and Android devices worked normally. I have also been able to play the album again without problems, and now showing the correct track titles.

I think I was lucky that the iOS device was able to talk to the core, otherwise I would have been completely stuck.

Reporting this in case it’s evidence of a defect that needs to be fixed.


Hello @thumb5 ,

Thank you for the report!

Do you by any chance still have Roon log files from this interaction on the Mac? You can access Roon logs by using these instructions, if you can upload a set here, we can take a look to see if the logs contain any clues:

Are you able to reliably reproduce the issue with this same album? Is there any way you can record a short video and send it to us so that we can try to reproduce on our end?

Let us know, thanks!

1 Like

Hello @noris,

Thanks for your reply. I’ve uploaded the compressed log directory via the link you provided; the logs of interest are from the morning of 25 December 2021.

I haven’t tried to reproduce the problem, partly because I’m concerned that it might leave my Roon Core inoperational. If the logs and my description aren’t sufficient, and you can let me know of a method to re-start the Core without it causing the same problem immediately, I’ll give it a go.


1 Like

A post was split to a new topic: Roon Remote Crashing

Hi @thumb5 ,

Thank you for the additional reports here. I have spoken to our QA team and we have been able to reproduce the issue on our end and have filed a ticket for the development team to look into this further. I can’t quite comment on a timeline of when the issue will be fixed, but we are aware and tracking this!

Thanks for the update, @noris. Good to hear that you can reproduce the problem and hence (hopefully) work out the root cause and how to fix it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.