Roon remote crashing after idling and dropping from core [Remote Connection]

This problem has persisted through all the updates and hasn’t really bothered me but figured I should bring it up in case it’s not something on my end or in case others are experiencing similar problems.

I have Roon installed on my desktop as a remote. It connects to the core which is on the PC connected to my stereo which is always on.

I never close the Roon application on either PC but at least once a day when I maximize Roon on my dekstop after it has sat idle it ends up crashing. The sequence of events is usually as follows.

-Maximize Roon after getting home from work.
-At this point it has always disconnected from the core and is searching for a library.
-It will never find the library so I click the cancel and select new library
-After re-initiating a search it sees my core pc
-Select the core PC library, Roon gets to the overview screen and within seconds completely shuts down without warning.

Remote desktop PC is win 7

Library PC is win8.1 and never has problems as far as I can tell, I run it headless so the only thing I can think is maybe its crashing and restarting on its own and when it crashes it loses connection to my desktop, and my desktop cannot reconnect when it starts back up. Though that doesn’t explain the desktop crashing suddenly upon manually reconnecting.

Any ideas?

We’re aware that there are some unreliability issues surrounding servers and remotes. At least two are fixed for next week’s release, though it’s hard to say whether they correspond to the problem you’re experiencing or not. We still have some stuff we are struggling to reproduce in house.

@mike, lets get some logs from @robbbby (both from server + remote). Maybe they have a clue.

Going to follow up via PM @robbbby – talk to you soon.

I’m having an issue with the remote simply crashing within 10 minutes every time. I can play music initially, but then that stops after a few minutes. And then I get the message “Lost Connection.” Occasionally it comes back on it’s own but usually it requires closing and reopening Roon on both machines. My remote machine is a MacBook Pro running OS X 10.9.5 on a 2.8 GHz i7 chip. The server machine is a Mac Mini running OS X 10.10.5 on a 2.6.GHz i5 chip.

Sometimes connection issues can be resolved by giving your Core machine a fixed IP address in your router.


I also came across another possibility I will address: Mac Minis apparently are prone to WiFi interference from BlueTooth devices like keyboards and mice. I’m going to change the wifi channel at some point tomorrow and see if this fixes it.

But thanks for you insight, too. Will try that as well.

Hi jlo,

Is it possible that you have two Roon databases in use ? This could occur if, for example, you originally ran Roon on your MacBook Pro and then subsequently installed it as a Core on your Mac Mini without doing a fresh install on the MacBook Pro.

To check that there are no conflicting database issues you might:

  • backup the Roon folder on the MacBook Pro (from an abundance of caution);
  • uninstall Roon on the MacBook Pro, deleting the Roon folder;
  • do a fresh install of Roon on the MacBook Pro

If your MacBook Pro was a fresh install, then it is unlikely that this is the problem, but there is no harm in trying a fresh install to see if that resolves anything.

As you will see from the threads noted by Roland there are a number of people having Remote Connection issues and the devs are currently trying to reproduce them.

No, just one database. I ran Roon off the Mac Mini for a week or so before loading it onto my laptop.

A build fixing some connection bugs that have been identified will be released in the next few days:

Lets see if that picks up this issue.

Hello @jlo are you still having the connectivity issue ? Yesterday we’ve released a new build, try to update your client. If the issue persists feel free to ping me and I’ll try to help you.


I’m still having issues. I’ve got the latest build. I’ve tried the Bluetooth fixes as well as change in wifi channels fix and those don’t seem to work.

What does work is to close Roon on the server machine, close it on my laptop, and then re-open them. Kinda of a pain, but the only thing that seems to reconnect them.

Sorry to hear that jlo We’ll leave a notification for @vova to investigate further.

Hey @jlo – I just sent you a PM with instructions for sending us some logs, so we can take a look at this. Sorry for the trouble!

Hi, I’ve been out of town for a week. I will check this out and send logs back, hopefully this weekend when I have a few hours to sit down with the program.