Roon remote doesn't work with Android 11.0

Core Machine (Operating system/System info/Roon build number)
Dell Inspiron 5521 w/ Intel Core i5-3337U @ 1.8GHz; 8GB RAM.
A Galaxy S20+ 5G is running the Roon Remote app.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Synology RT-2600ac router connected via ethernet to WD My Cloud, the Core and a Chromecast Ultra.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Chromecast Ultra.

Room remote can’t find core after update to android 11.0. I’ve reinstalled the remote a couple times and it doesn’t work.

Update, sometimes it works, sometimes it doesn’t.

Hello @Cale, do you have any luck if you search for the core by IP address? Was this remote working fine before the update?

No, searching by IP address makes no difference. It still takes several minutes to find the core after I open the remote app. When I’m done using the remote and my phone’s screen turns off, the Roon remote closes. When I try to open the remote again, the lengthy core search process starts all over again. This has made the remote mostly useless.

It worked fine before the update.

Cale have you tried removing and reinstalling the app? I had some problems with Android 10 update like that. Though Android 11 and Roon have worked perfectly (with me setting the IP address of the Room server.



As I said in my original post, I’ve uninstalled and reinstalled the app several times and the problem persists. Roon worked fine until my phone updated to Android 11.

Searching by IP makes no difference.

Sorry Cale I missed that in your post.
There were a lot of network stack changes in Android 10 but not a lot in Android 11.
I guess nothing else in your environment has changed.
Does to your router have an option for IGMP Snooping?


Instead of the IP address try

Yes, but I have no idea what it does and if I change it what other problems will arise. Right now it is enabled. That is the default setting as far as I know.

From memory it is meant to be turned on

Unfortunately I don’t have any Samsung phones in my house to test


Hello @Cale, did you try the address ged suggested as well?

It’s working better now (though noticeably worse than before the Android update) and I have no idea why. I tried GED’s suggestion, then suddenly the remote app notified me that a software update was available. After the update, the remote will connect but there is still a connection time lag that is longer than it used to be. Whatever - it’s functional.

Thanks all.

I had the same issue after upgrading my Samsung Galaxy S10 lite and my Google Pixel 4XL to Android 11. @ged_hickman1 's suggestion solved the issue. Now Roon Remote connects also without manually entering

Still think, this needs some looking into

1 Like

A post was split to a new topic: Samsung Note20 Ultra connection issue

Just notice same problem after android 11 update on Samsung note 10 ultra.
I think roon should fix this bug. Rather than change IP address.
I have multiple remote points;
Windows pc
Samsung tab4 still running android 10

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.