Roon Remote (iOS) intolerably slow

Hello my connection using Roon Remote on my iPad has been slowing to an almost grinding halt.

When playing music stored on the NAS the remote app is so slow as to be almost unuseable, anywhere upto 30 seconds of wobbly jellyfish per action even just clicking the back and forward arrows.

Loading a screen when an album is playing takes around 18-25 seconds. Even if I momentarily press the iPad home button and then click back on roon it appears that the connection is lost and the page has to reload.

Is there anything I can do as having paid for a full subscription it is becoming unusable.

NAS: QNAP TS-253A(4GB Ram) 1.6ghz Intel Celeron

Roon databases installed on dedicated SSD connected to NAS using USB.

NAS connected to router on network which wifi averages a round 14-16 Mbit/s

Roon remote (iOS) on 16gb iPad with 14gb free memory.

Your NAS is underspecced so I would look there as a first issue. Do you have a PC you could move the core to as a test?

Agree with Ged, maybe restarting the nas will help too but it’s likely to be the issue of cpu speed and ram being not near enough close to minimum specs

Thanks for the replies. Any idea why this has suddenly happened though? It used to load details instantaneously

What are the minimum specs?

Have you tried rebooting everything including network switches?

I have rebooted the NAS and reinstalled roon remote.

I have no switch on the network and the NAS is connected to the router via ethernet cable.

I only use the NAS for roon.

As i say, the deceleration began a couple of months ago and got rapidly worse although there has been no (known) change to the set-up.

Do you use any dsp functions or features? Are you importing new music?

All DSP presets are disabled.

System is in a ‘steady state’ in as much as nothing extraneous is happening, imports or otherwise.

Flagging @support for you and maybe @crieke Chris could help here too

Thank you. I had thought this was going to be an App/iOS issue but it looks like it might be a bit more deep seated!

This sort of slowdown often turns out to be either a server problem or a network problem.
The other thing to try is to deinstall and reinstall the iPad app.

1 Like

I’ve now reinstalled roon server on the NAS which has seemingly fixed things when playing music from the NAS…

…but has created a new problem which is that Roon Remote is now taking a long time (~5-10 seconds) to reinitiate, load images, pages, etc when accessing anything through the TIDAL service. This was previously unaffected.

What the Lord giveth the Lord taketh away.

Would upgrading the RAM (4GB to 8GB) on the NAS have any worthwhile effect?

I’ve rolled back the firmware on the NAS and that has sorted the problem.

For some reason on the most uptodate QNAP firmware the ‘roon appliance’ process was running at 8% CPU usage when idle and up to 25% when playing a tidal track through Roon.

After rolling back the firmware the ‘roon appliance’ process is far less demanding of the CPU and all is fixed. I’ll wait for the next firmware update to see if I can roll forward successfully, skipping the one which is causing the problems.

With thanks to all those that tried to help here.

Can you let me know, which QTS version did cause the issues? Was it
I will test it with my library here then.

No, I hadnt gone that far forward! It was one of last November’s releases but I’m working away at the moment and dont have access to the logs. I think I just went back to the previous (~October?) release and everything cleared up. The very fact that I had said that it had been happening for a couple of months should have been enough anecdotal evidence for me to have linked the fault with the firmware release timing but I’m too keen to blame the ISP or the iPad before I look at the server!

When I get home Ill roll right forward to the current release and monitor.

If the fault reappears Ill certainly let you know but please dont feel like you have to try to replicate this as it seems very much specific to my setup.

Kind regards

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.