Roon Remote iPad App Constantly Crashing

Roon Core Machine

Roon Core = 2014 Mac Mini 500SSD 128GB
iPad = MD788LL/B
Roon app on iPad crashes after 5 minutes of use on a regular basis.

Roon core connected over ethernet. iPad access over WiFi - in same room as router.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

@Robin, have you tried deleting Roon from your iPad and reinstalling it? Also, what version of iPad do you have and what iOS version are you running?

The iPad Air and iOS are supported for this. Did you try deleting the Roon app on the Air and reinstalling it? Have you also rebooted your Mac mini Core?

1 Like

Yes both. :frowning:

Can you please post a screenshot of your Roon’s Settings → About tab which displays the version of Roon you are using for your Core?

Thanks @Robin, everything looks up to date and correct. I am tagging @support for assistance. As you did not see a change in behavior after reinstalling the Roon Remote app on the iPad and everything else seems correct, I am just about out of ideas.

Except for one more idea. Do you have an iPhone that you can test? What is the exact behavior you experience? A hard crash or a stuttering of the music?

Hi - the iPhone app works perfectly - I’m just having issues with the iPad :frowning:

Let’s see what support can do when they return to the office this week.

Hi @Robin,

The only thing I can come up with is that the Air you have is the first supported model and it’s almost 10 years old. I’m trying to find out whether or not our supported models have changed in the most recent updates though. I don’t have reason to believe that they have other than the situation you’re reporting.

Our KB definitely includes yours:

Do you happen to know how you’re doing on free space on the iPad?


1 Like

IOS for iPad is now at release 16.3 & your screenshot indicates an out of date 12.5 version. Perhaps you might try upgrading your firmware, delete the app entirely, cold start your iPad and Roon system and try again. Good luck…

Hi @Robin,

After a stellar suggestion from @Geoff_Coupe, I’ve found something that might be relevant. It looks like both iOS and macOS use the page file system to allocate memory (just like Windows). This was a surprise to me since I’m intermediate with Mac but expert level on Windows.

Here’s what I found:

Both Mac OS X and iOS include a fully-integrated virtual memory system that you cannot turn off; it is always on. Both system also provide up to 4 gigabytes of addressable space per 32-bit process. In addition, Mac OS X provides approximately 18 exabytes of addressable space for 64-bit processes. Even for computers that have 4 or more gigabytes of RAM available, the system rarely dedicates this much RAM to a single process.

Your 3.5 GB free might be the issue here. I highly recommend freeing up some space and as @Doug_Lang mentioned, ensure the OS is up to date.

Let us know! We anxiously await your update!


1 Like

Edit, the thanks goes to @Robert_F. I misattributed the suggestion.


1 Like

Similar problem.

iPad Air 2 64GB (55GB available)
Fresh iOS install as of 10 min ago - iOS 15.7.3 (all updates installed)
ALL possible apps uninstalled, incl. mail, contacts, etc. There is basicly only Roon and Safari left.
The lastest Roon 2.0 app downloaded from the App Store.

The app has run the first time, but crashed during initial Roon setup. I have tried to reboot the device 3x already, but I’m still unable to launch the app - it crashes every single time on startup. It shows Roon logo, then the screen goes blank and next thing I see, is desktop.

Hi @Elberoth,

I’m certain that this is tied to the instance of ROCK having an older build installed. The odd thing is, I can see that it’s online but it won’t respond to me. Do you have any particular firewall or security setup that could be hindering this?

In theory, it should be as easy as going to rock.local in a web browser and clicking reinstall. If that installation fails my aforementioned theory could (and likely does) apply.


  1. I have installed the latest ROCK build (I have just downloaded it from the Roon website).
  2. All the updates have been installed
  3. Roon App works on my iPhone 13 pro and iPad 10-gen without any problem. All on the same network.

As soon as I try it on the iPad Air 2 - it instantly crashes.

I have also tried it in a shop - completely different network, exactly the same outcome.

Hi @Elberoth,

I am unable to confirm that this update occurred. The core is not responding to my requests for diagnostics logging or attempts to remotely flag for updates.

Can you elaborate on what you mean by this? ROCK should be getting updated via Roon>settings>about or via rock.local in a web browser.

Can you give me a screen shot of what you see in Roon>Settings>about?


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.