Roon remote loose connection with Huawei P30 Pro

Core Machine (Operating system/System info/Roon build number)
Intel NUC i5 with Windows 10.
Roon build 521.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Router from my ISP deliverer.
NUC connected with ethernet. Huawei P30 on wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Volumio Primo to DAC. Volumio connected with ethernet and with USB to DAC.

Description Of Issue
I have an issue with the Roon remote when using my Huawei P30 Pro. It looses connection constantly and won’t connect again until I flick the switch for remote connection in Roon core.

Today I tested my old Huawei P10 Pro and it works flawlessly. What could be wrong with my P30 that it wont allow remote connections?

Since it works with my P10 it must be something wrong with the P30.

Hi @Robert_Nilsson,
I’ve moved your post over the the #support section and dropped in the pro-forma questions.
Could you edit your post and complete those sections, which will aid Roon’s @support team.
Many thanks.

Thanks. I have updated my topic.

1 Like

Hi @Robert_Nilsson,

Any change after rebooting the remote or reinstalling the app on the remote?

After rebooting the core it works until next time the connection drops. The connection usually lasts about 5-10 minutes. If I’m active in the app the connection does’nt drop but if I exit the app or if the screen goes black the connection drops quick.
No change after reinstalling the app.
If I flick the remote connection switch in the core when the phone is trying to connect it connects instantly. If I dont flick the switch it never connects.

Hi @Robert_Nilsson

Is the P10 and P30 connecting to the same access point/router or are they located in two separate rooms?

What is the model/manufacturer of your router? Sometimes specific routers require special settings applied to them to work properly with Roon, I’d like to verify if your router is on this list.


The p10 and the p30 is connected to the same access point. So the problem is not in the router it must be something with the p30.
I dont know what the manufacturer is on the router. It does’nt say.

Hi @Robert_Nilsson,

Which version of Android are you using on the P30? Is it up-to-date on latest firmware?

Android version 10. It is the latest firmware.

Hi @Robert_Nilsson,

Can you please note the exact local time + date this behavior next occurs? I’d like to enable diagnostics mode and take a look for any further clues there.

Found another thread today when googling on my problem. It was others who had problems when connecting with Android phones and tablets. Someone wrote that they put in in the core ip adress and it worked.
I tried doing the same thing and now it works every time! :slight_smile:
What could be the problem?

Hi @Robert_Nilsson,

The workaround bypasses the ability for specific multicast connection and sends a multicast packet to all devices on your network.

Generally, if you can connect using the workaround but not without it, this suggests that something is going wrong regarding multicast in your setup.

I know you mentioned you have an ISP router in the original post. Generally speaking, we have found that ISP routers are not great at passing multicast traffic properly.

In the past, we have seen router settings such as IGMP Snooping or IGMP Proxying help in similar situations, so if you are able to access the router’s web interface and locate such a setting it would be useful to try enabling it (or replacing the router outright with a consumer-grade one).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.