Roon Remote no longer connecting and cannot upgrade to Roon 2.0

Roon Core Machine

MacBook Air M1
Roon Remote on Ipad

Networking Gear & Setup Details

MacBook connected via ethernet and powerline adaptor

Connected Audio Devices

Devialet Expert 200 connected via ethernet and powerline adaptor

Number of Tracks in Library

Circa 5000

Description of Issue

Roon Remote on my iPad no longer works since you updated the version in the App Store to 2.0. All apps on my iPad are updated automatically so will have updated to 2.0. Not that doesn’t talk to my Roon Core which was 1.8. I looked in the App Store and discovered you have added a Remote 1.8 which I tried but that also won’t talk to my Roon Core 1.8.

Then I tried updating my Roon Core to 2.0. Spent about three hours trying that but that was a pretty disastrous and frustrating experience. I would have expected to get a message from my Roon Core 1.8 inviting me to update but it didn’t. I looked for updates - I got a message saying update checking has failed.
I tried downloading the Roon 2.0 dmg and running that. Logged in to Roon, using my account details. Logged into Qobuz, then pointed Roon to my file library on Sinology NAS. Then…nothing. Roon shows no tracks, no albums, no access to Qobuz.

Running out of ideas here. I just want to listen to my music not spend hours trying to fix IT issues. Please help!

The Roon 1.8 checking for an update line in the above dialogue stays like that permanently and never finds one (spinning icon).

This is what I get if I try to install Roon Core 2.0 following your online instructions. It shows no music files, no audio devices, nothing.

I’ve read elsewhere in these forums that the user needs to run 1.8 Legacy on the Core as well as the Remote. The download is called 1.8 Legacy. The normal 1.8 will not work.

Yes you may well be right but I can’t seem to install any new versions of Roon, or at least when I do they are unresponsive.

I know the territory these days with shareholders demanding new features rolled out frequently that result in inadequate software testing. That’s why I never upgrade to new major versions of almost any software on release - I wait for the following minor bug fix releases. But being forced into updating and having to install a different version of the same version I’m already running just to keep things as they were? That’s a new one on me. Very poor user experience Roon! I see I’m in good company too with many others having similar problems. Very disappointing.

Saturday evening and have some free time so was looking forward to listening to some music on Roon. Oh well, guess I’ll dig out the old Linn streamer. Not such a good user interface but I can rely on it to work and I don’t need to become a software engineer to operate it.

And while I’m ranting, do I really need to receive a Roon security alert email every single time I log into the Roon community support website from the two devices I have used for this many many times before?

Too late now, but for future releases, Roon doesn’t force you to upgrade.

For your iOS devices, turn off automatically updating App Store apps.

This really bugs me, also. No way to stop it other than sending Roon e-mails to your spam folder, AFAIK.

I have way too many apps on my iPad to want to manually decide which to allow to update and which to block. Once the remote app updated it effectively forced me to update the Core as well since the updated app won’t work with 1.8 and I can’t reverse the remote app update and the new remote 1.8 doesn’t work with Core 1.8 it seems to work with some new variant of 1.8 which has to be updated…… arghhh, you get my drift…

My Roon Core was already set to not update automatically.

Ok, then you’re going to get whacked every time Roon has a new release. Roon can’t control how App Store apps are updated. The App Store controls that.

Good luck with your problem. I don’t speak macOS, but I can tag @support for this.

Ok thanks. Roon controls when it submits app updates to the App Store and what’s in those updates. I’m not a developer but can’t see why it’s beyond the wit of man for an updated Remote App to have some backwards compatibility and be tolerant of at least the previous version of Core that most people will still be using at the point when the app update is submitted to the App Store.

Hi Jonathan,

I posted with basically the same problem that you are having. No assistance has been forthcoming that resolves the issue. I am a lifetime member. This “upgrade” effectively prevents me from using Roon. I am now streaming Qobuz so at least I can listen to music. I am locked out of my 3T library. Color me very unhappy.

Good Luck.

Rob Stone

Thanks Rob. I sympathise completely. Pretty miserable update experience. Real shame as I was very happy with Roon and liked what I saw of the company ethos.

I have now solved the main problem though - after trying to update to Core 2.0 unsuccessfully, then back to 1.8 and then trying 1.8 legacy still with no success I decided there was no option but to wipe everything and start again with a clean install of 2.0. Seems to have worked although painful to wipe the database. New database building now.

Seems to be working and Remote connects again. Will now have to try it for a few days to see if it’s stable and has no other bugs waiting for me…

All the best with getting yours fixed.

If you have a database backup, just restore that.

In this case, a V1.8 database will work with V2.0.

Ok thanks, will note for future reference. I deleted everything this time because I didn’t know what files were preventing the install of Roon Core 2.0 from working.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.