Roon remote no longer connecting to SonicOrbiter

Core Machine

SonicOrbiter 9i 8TB running 2.8 OS containing Roon core.
Mac OS 10.15.7 MacBook Pro mid-2014

Network Details

Ausus 6G router and wifi (whatever they mean by that: sure I don’t have 6G but it is their latest and greatest model)

Audio Devices

Library Size

About 6TB or so

Description of Issue

Roon no longer connects to Core. I’ve rebooted the Mac, the SonicOrbiter, the Roon Core on the SonicOrbiter, all to no avail.

Andrew from Small Green computer just “cleaned up” the SonicOrbiter, I was thinking that might be the issue, but it isn’t. Anything else I can try?

Hello @soyka0120,

I’m so sorry to hear about the trouble…:sweat: . We’d love to help.

To make sure I’m not missing anything, your Roon Core is the SonicOrbiter and you’re using a MacBook Pro as a remote to control it. Your Mac no longer connects to the Roon Core? Do you have any other device you use as a remote (a tablet, a phone or a different laptop/PC)? Does that work?

Your understanding is correct. I have remotes on the MacBook, an ipad4 and and iPhone 5s (I kno wI’m a Neanderthal). None can connect. Thanks for the quick attention.

what changed since it was working?

If its a new router then perhaps the wifi IP range is different than the LAN based one?

Roon needs all devices on the same IP range ie where xxx is unique usually in the 1-254 range.

a guest wifi network is special and wont allow other devices to see/talk to another but will only allow internet connectivity.

need more info on how the devices are connected.

No change in the wifi configuration. The Sonictransporter is at, the Asus RT AX88U router/wifi is so presumably that is accurate. Apparently what changed from when it was working to when it was not is that when at first I lost connection I assumed it was due to a home power loss (nothing new and it is connected to a UPS. Andrew at SmallComputer did a diagnostic and apparently I was sending Roon backups to the ST which over all the time I had it overloaded the OS. So he cleaned that up, I upgraded the ST OS to the latest version but still can’t connect. Everything else on the network (HDs, MacBook, iPad, printer, etc) is connected and working.

I tried looking at the settings for Roon, but I’m on the “Waiting for remote core” screen and nothing comes up. This is the case across all three remotes (MacPro, iPad, iPhone). I’ve rebooted everything several times, but nothing changes.


Hey @soyka0120 thanks for keeping in touch and for responding to @wizardofoz’s question (it’s a great one - thanks!)

I’ve looped in our technical team so they can share their insight into what might be wrong. Please, bear with us a little longer.

Hello David,

Just a fellow SonicTransporter user here.
While you await feedback from Roon support, I wonder:

  • can you access its web interface at ? If so,
  • is the Roon service running? (Under Apps - Roon Server)
  • have you tried to stop and restart the Roon Server?
  • have you tried to reboot the SonicTransporter (System - Reboot)

From your post I understand you tried all that, but very occasionally after a software update or significant configuration change, I have had to trigger more than one boot cycle to get it into a stable state and make Roon Server and everything else visible on the network.

If you already tried the above, please ignore.
Hope you get it sorted soon!

Thanks, appreciate the advice from a fellow Sonictransporter. Alas, I think I’ve tried this process a half a dozen times, but to no avail.

1 Like

Still haven’t been able to connect despite multiple reboots to try just for the hell of it. Since I can’t seem to see my Roon preferences (shouldn’t I be able to, even if I can’t connect?) to the core, I’m wondering if I should try Select a Different Core and try to reconnect (meaning I’m not selecting a new core, just connecting to the same one). I’m a little hesitant to do that, see as how there’s a warning about accessing your music, though I’m not sure what that exactly means. @support

what does your roon remote screen look like…do you see more than one option for connection?

Just this:

It’s not letting me do anything else.

check on need help and enter as IP address and see if that gets you anywhere.

You mean to enter the IP at “Select a different Core”?

And if I select a different core and want to go back to my “old” core, does that affect my music library in any way?

Just took a look at my network preferences, they seem to be correct (I think).

Hi @soyka0120 ,

Thanks for your patience here while your case reached our queue!

Yes, you can click on this button without issue, it takes you back to the select your Core screen, but if the SonicTransporter is not on or there is an issue with the connection, the Core still may not show up.

Can you please verify these two aspects and share a screenshot of the settings there? You should check the SonicTransporter to make sure it’s running in the SonicTransporter Web Interface:


The ST is running (though it’s at .16 and not .4 if that makes a difference. Also, it shows up on Finder and is connected to my network. I also restarted the server (I’ve done this several times) and ran the diagnostic (see below). I went ahead and clicked the button to select my Roon Core, but it hangs up saying “Looking for Roon Core” without finding anything. @noris

Just a quick update. I’ve clicked the Look for Roon Core button and it still isn’t finding it. Rebooted ST and MacBook several times to no avail.@norris

Hi @soyka0120 ,

Thanks for sending that screenshot. Based on the screenshot, it doesn’t appear that RoonServer is starting up properly, do you have any backups of your Roon database?

I suspect that the quickest way to get up and running again would be to clear out the current database, make sure it boots properly on the fresh database and restore from a backup.

If you don’t want to perform this clear/restore procedure, then the next suggestion would be to show those screenshots to SmallGreenComputer support staff and inquire as to why RoonServer doesn’t appear to be booting properly.

How can I clean up the database if I can’t access anything in Roon beyond the Looking for core screen?@noris