Roon Remote No longer working 1.7 Build 511

Roon 1.7 build 511 , latest update taking place on the 29th I think.

Here are the symptoms from TODAY Jan. 3 only, after the latest automatic update:

  • The Roon core takes 5 times longer to start.
  • Everytime it restarts, it says the change of version requires to restructure the library or something like that, that takes another minute or so - why every time ? If restructuring is needed, it should be only the first time not afterwards.
  • my iPad Roon Remote can’t fine the Roon server anymore (VERY annoying)
  • my iPhone Roon Remote can’t either.
    I am running Roon server of Mac Book Pro 4 cores i7 @2.6 GHz, OS is Catalina 10.15.2. Music folders on Airport Express Disks - what else can you do with a big library and a SSD Mc Book Pro whose USB cable has to connect close to the converter (Neutron Star DB Systems), via HQplayer.
    This is annoying and unwanted. Until yesterday everything worked fine. Upon updating Roon it was longer once, for updating the database.

As a side remark, why would on one side Roon manage streaming from distant DB (Qobuz, Tidal) and not manage properly local database folders on Wifi LAN network, that has larger bandwidth, shorter latency and warranted availability ? It should manage local network disks seamlessly, period -and it seems close to doing it so please make this thoroughly.

And I forgot. For the last two days, I have been experiencing dropouts that virtually did not happen before. Something is really dysfunctional and it appears directly linked to the latest release.

Hi @Christian_DEPLANTE,

I don’t believe that this issue is related to our recent release, I haven’t seen reports of such behavior on MacOS. Instead, I believe this issue could be networking-related.

Can you please provide some more information regarding your router’s model/manufacturer? How is the Macbook Pro connected to the network, via WiFi or Ethernet?

Yes it looks you are correct, it would be not a new release issue, rather a network issue but not a trivial one.

I had tried to restart the Roon server and the iPad, as well as to restart the main network wifi borne. But this morning I shut ALL devices on network and restarted all in a logical order. And it came back nice.

However something must be sensitive as while Roon Remote did not work, Roon could still stream music from the server (including the WiFi-connected files) and everything but Roon Remote was working fine.
By the way I note an improvement of sound when I put all apps to sleep on server (possible in last release of Catalina) except for HQplayer and Roon.
Thanks for your reply and I hope this clarifies. Roon/HQplayer has brought me unsurpassed sound quality once proper settings were found, and an improvable (network storage volumes, playlists, search, gathering, new version of DSP equalizer inferior to old one), but still excellent ergonomics. I use Roon/HQ for 90% of the music I listen to.
Happy new year and continue maturing the product !

Sorry, but the same happens again tonight while Remote was working this morning. Meanwhile there might have been some short power outing as I had lost one of my links to remote discs.
I spent some time to make sure it would restart clean.
But now it all restarted well (including the time capsule) and Roon works perfectly…but the Roon remote still refuses to connect.

  • I concur there might be something in relation with my network configuration and the fact that I use Network Wifi disks.
  • However this is a direct consequence of the hardware choices (MacBook Pro)
  • Besides, using local network disks should not be an issue at all for Roon - it manages distant disks for streaming !
  • The only thing that seems super-sensitive to some tricky network issue, is Roon Remote.
  • And finally what is the risk at changing core in Roon Remote ? The message you provide For changing Core on Remote, sounds like it could affect also the Roon library itself. So I wait for your answer on this before trying to change Core.

Overall the ball is definitely in the camp of Roon Labs to make Roon Remote as robust as Roon itself. You guys are the network specialists, not the users.

Thanks in advance for looking at this in sufficient detail,
Best regards, Christian

Hi @Christian_DEPLANTE,

Happy New Year to you as well!

What is your network setup like, can you list the model/manufacturer of all your networking gear? If your router up to date on latest firmware?

Since this behavior impacts both the iPad and iPhone, we should take a look to see how the Core is connected vs these devices. Are they all on the same subnet when this issue occurs?

I am not quite sure I understand. You can feel free to set your Roon Remotes to connect to which Core you prefer, the database lives in the Core, not the Roon Remote. If you were however to designate a new Roon Core, the old database on the previous Core would still remain there and you would have a fresh database on the new Core unless you perform a backup + restore. Does that explanation help?

Hi, I have no more problems, since I have completely shut down all devices including airports and rebooted everything in logical order.
Unclear though… Again one of the issues is that in my opinion, Roon should accept completely the library paths that are network volumes. When one uses a laptop as Roon server, this is not to have to carry it along with X USB disks attached…
Thanks, CD

1 Like

Hi @Christian_DEPLANTE,

Glad to hear that the issues have been resolved.

Thanks for the feedback here. Since this appears to be “working as designed” I would recommend also posting your suggestion in the 'feature request" section of the site.

Our product team and developers keep a close eye on that category, so that’s definitely the best place to propose a change like this and get feedback from the Community.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.