Roon remote not working on Android (Sony Xperia Z5)

Core Machine (Operating system/System info/Roon build number)
Antipodes EX on latest Roon 1.6.1
Sony Xperia Z5 Android Remote.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Everything connected to Ethernet via switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB out from Antipodes to DAC

Description Of Issue
Have had problems with Roon remote every since I got it on my phone with this setup, it can never find the core.

I tried re installing, deleting cache restarting Roon core in Antipodes management menu but still no luck.

I can play Roon fine when I’m controlling it through the desktop to playback from the EX.

Verify that the smartphone is on the same network subnet as the Antipodes. ( The first 3 IP number sets match, for example, 192.168.1.x )

If the above is correct, you might try the trick where in the input of the server’s core IP address, you put and see if that works.

Hi @Yuri_Hajtko,

What kind of switch/router are you using? If you are using a managed switch, these have sometimes have caused issues with Roon in the past. As per our Networking Best Practices:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Since you are using a Linux Core and an Android remote, I would also take a look to see if your router/switch has an IGMP Proxy / IGMP Snooping setting as these have helped similar issues in the past.


I’m using a TP-Link TL-SG108. Doesn’t look like a managed switch. How would I check for this proxy?


Hi @Yuri_Hajtko,

Yes, the TP-Link switch you listed appears to be un-managed so it won’t have any configuration options. The IGMP settings should be on the router, not the switch in this case. What model router are you using? Does it have a multicast section for settings?

@noris I have the bell homehub 3000 from Bell Canada which is a SageComm Fast 5566.

I checked the router setttings in the web management portal and I only see IGMP under statistics in advanced tools but nothing that I can change as far as I can see for multicasting or I’m not sure how to di it.

Hi @Yuri_Hajtko,

Thanks for providing the router model information. Since this is an ISP provided router, we have often found these kinds of devices to be sub-par when attempting to use Roon with them, as mentioned in our Networking Best Practices.

I suspect that something is preventing multicast from operating properly on this router, but there one other test that we can use to narrow the issue down. Can you try to manually connect to the Antipodes by specifying the IP address on the “Choose Your Core” screen? You can specify the IP address after pressing “Help” when the Core is not located.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.