Roon Remote on Win 10 is unable to connect to the PC sound output device --> no playback possible

Core Machine (Operating system/System info/Roon build number)

Roon Core is running on a Synology Diskstation 918+ (8Gig Ram; 10 TB Storage, usb thumbdrive with 256 GB for Roon system files)
Downloaded from here:
The Core is running perfectly fine

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Router: AVM Fritzbox 7490
Switch: Netgear 5-Port GS105
Gigabit Ethernet Cat-5 Cabling
No network problems so far…

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Apple TV - working fine as a output device for roon
RasPI running Ropiee - working fine as a Roon endpoint
Windows PC running Windows 10 , which is having the problems
2 iPads with roon remote - working fine
1 iPhone with roon remote - working fine
Roon remote running on my Win10 PC is running fine an can connect to the RasPi and the Apple TV for output, but does not connect to the onboard sound device on my PC.
I use the onboard Realtec Audio Chip on my ASUS Crosshair VII Motherboard, which plays perfectly fine outside Roon (e.g. direct output from the Qobuz app)

If i click on “Settings / Audio” i can see all my output devices for about 5 seconds then they disappear and i cannot select any output device.
Roon remote tries to connect to the systems default output device but after about 5 secs it fails and all the entries disappear…
Instantly clicking on one of the output devices to enable them specificly does also not help

And last but not least: i did not find any solution after thoroughly searching the Knowledge Database / FAQs / Forums

Thank you in advance for your kind help!

Best regards

I disabled the win 10 firewall, just in case, but no change.
I also tried to disable all other devices except the main audio output, but no changes at all


Make sure you use the latest driver for the Realtek onboard audio device.

I do have the latest drivers…
So this should be fine i think


Super strange!

Just out of curiousity i reinstalled the latest drivers once again (so no update effectively, just the same driver as already installed)
Started Roon remote and it worked - BUT:
I rebooted the machine and i had the same problem as in the beginning…

should i access any logfiles to find out what is happening here???

This is crazy :crazy_face:

Have you used the manufacturers site to check that?
OEM’s frequently offer old drivers on their homepages.

I have used the download from ASUS
More specifically the download for my motherboard (Crosshair VII hero)

I will check the realtek site for the drivers…

Hmm, it seems i can’t find the appropriate drivers on the Realtek page.

On my motherboard is the following soundchip:
ROG SupremeFX 8-Channel High Definition Audio CODEC S1220
Supports up to 32-Bit/192kHz playback


Hi @Georg_Hutter,

If you temporarily disable the firewall on the Windows device is there any change?

Hi Dylan,

i completely disabled Windows Defender and i also disabled my Acronis Active Protection
So as far as i can tell there should not be any firewall or ransome ware protection active

unfortunately no change :frowning:

This is what my settings / audio Tab looks like forever after clicking on “enable”:

Again: arent there any logfiles i can check to find out what’s happening?




I also have a Steelseries Arctis 7 wireless headset connected to my PC (via USB dongle)
And also i cannot connect to this device, which is not related to the Realtek drivers (i suppose)

So i think something is blocking Roon remote to connect to ANY audio output device

You can also try to use the System Output (which is Windows very own mixer) or the Realtek ASIO device.
If these two should work, then there’s maybe a problem with WASAPI-drivers (maybe introduced with recent Windows updates).

Hi BlackJack,

i have tried EVERY output device with no success :cry:

So i think something is preventing Roon Remote to connect to ANY output device on my machine


I uninstalled everything (Audio drivers, Roon, ASUS Sound Manger)
Then i rebooted and reinstalled everything from scratch
I was able to connect to the Realtek ASIO interface (which i was NOT before)

Sigh - with computers we are solving problems which we would not have without them :rofl:

Thanks for your support efforts guys :smiley:

Kind Regards

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.