Roon remote on Windows 10 hangs up

Core Machine (Operating system/System info/Roon build number)

Roon 1.7 build 537 on Ubuntu
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue

I have two Windows 10 computers that I occasionally use as remote for Roon. For months now there has been a point where Roon starts, but the start view is not completely loaded and Roon then hangs. The process can then only be stopped hard via the Task Manager.

The iPad works perfectly at the same time, which means the server runs correctly. I often helped myself with the iPad. But it was always annoying when the Windows computers did not work as remote again and again. All the time, some weeks or months later, Roon suddenly worked again.

Recently I had apparently found the reason: the problem was gone a few times after I did Windows updates. So it seemed that only Windows had to be always up to date. But since yesterday I have a computer with the same problem again, but now here is no Windows update available. The computer is up to date.

As has often been tried before, uninstalling and reinstalling Roon does not help.

What’s going on there? Gradually it is really annoying that Roon cannot be operated continuously from the Windows computers!

Best wishes

Sounds like a graphics driver issue. Windows update often overrides drivers.
I would go to the graphics manufacturer site and look for the latest drivers there. If it helps, download the driver to have it available if windows overrides again.
If it is inbuilt intel graphics go to the Intel site.

Hello @Ralf_Koschnicke, ged has a good suggestion here. Check if your graphics cards are up to date and let us know if that helps.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.