Roon Remote output problem - PC/Windows 10 [Resolved - Avast Firewall Adjustments]


I am having some troubles having changed my set up slightly.

I’m using a PC running W10 x64. I used to run Roon Core on this with my local music library (FLAC), but recently migrated to Roon Server (RS) on a SonicTransporter connected to my NAS (which has a mirror of my music library on it). I managed to migrate my database to the SonicTransporter and it works fine with my Squeezebox set up.

I now want to use the PC as an output for listening to my library (i.e. as a Remote, if I am getting the terminology correct!).

I had some teething problems with this (running Remote wouldn’t find the RS, it just stalled). I resolved these by completely uninstalling Roon Core (i.e. wiping settings and database as well as the program) and after reinstalling Roon I can now remotely connect to the RS and navigate around Roon on the PC.

What I can’t do is play music through the PC output - neither the System Output, nor the sound card, nor the onboard motherboard soundcard work. Whenever I select a track from an album, it skips through the album without any sound and without starting playback until it reaches the end.

Sound functions fine in other apps on the PC. Nor does trying to use JRiver MC work - I get an error message when that is attempted about the endpoint not opening (or somesuch) (this information is included for completeness, I do not want to use this but was trying to find a workaround).

I hope you can help!

thanks in advance.

Do you have a real sound card in this system ( as in a creative lab or Asus add in card) or is it just the motherboard audio. If it just the built in motherboard audio, Realtek sound card drivers have issues and won’t work properly. If this is the case (using Realtek driver) I"ll post what I did to correct.


Thanks for your post. I have onboard sound (RealTek in an Asus mobo) and a ‘real’ separate sound card (Creative Sound Blaster Z). My default is the SBZ, but I’d be willing to give RealTek a shot if there’s a solution for that…

Well, lets try the soundblaster. The symptom that you described can indicate that Roon was not able to get exclusive control of the driver. So, go to control panel, sound, choose the SB driver and click preferences, Advanced Tab and verify that both check marks under the Exclusive section are checked. Then make sure any other application on that PC that might interact with the audio is closed. Open Roon, settings audio driver, playback, make sure exclusive is on. I am assuming that the driver you are trying to us is WASAPI. Choose that zone and try playing something back.

Hi again

Thanks for your suggestions.

I tried these steps. The SB driver is given exclusive priority in Control Panel properties.

The SBZ appears twice in my Roon devices (WASAPI, as you say - also once as ASIO) - not sure why. I’ve tried these steps on both WASAPI instances (but not the ASIO).

In each case, exclusive was not on in Roon. I toggled it on, but no change. Then I toggled the ‘driver workaround’ setting, also without success. The same behaviour as before manifested itself.

I don’t get the ‘exclusive’ option on the System Output device settings page. but it’s still not working.

I’d welcome any further thoughts!


When I am trying different sound interfaces, I make sure to disable the other ones I’m not using. Also, I am assuming you did make sure no other software on your computer was running that might interact with the sound card. Actually, I’d reboot the system to verify that nothing else is stuck open ( I"ve had audio control be sticky by some programs, Jriver especially that I had to reboot the system before it released control).

And then I’d try disabling the WASAPI drivers and try using the ASIO driver. (Which honestly is the one I use in my system, albeit with a different sound card.

Under the ASIO settings I use Fixed Volume because I’m feeding a pair of powered monitors and use the monitors volume control. And everything else is just the defaults.

Hi there

Thanks again for taking the time to reply. I’ve tried enabling in isolation (disabling outputs not being tested). I’ve also uninstalled and reinstalled the SBZ driver and application from the Creative site.

I’ve also tried ASIO (and rebooted a couple of times in this process to see if that helped). Still no sound and ‘skipping’ through tracks! Any other ideas??

Might ask @eric to jump in as well to see if he has some ideas.

Just to make sure, the ASIO driver is the soundblaster’s, you are not trying to use JRiver’s ASIO.

Hi @LowKey ---- Thank you for your report and continued feedback. Daniel (@Rugby), thank you as well for your help/advice here.

LowKey, did you have any of these issues before migrating your core over to the SonicTransporter? As Daniel has mentioned in his post, we have indeed seen issues with the Realtek sound driver causing similar behavior your are reporting here but my assumption is that this would’ve surface before the migration.


Hi there

Fair question - I forgot to say that everything worked fine playing music in my PC before migrating to sonicTransporter. I don’t recall which output method I was using, probably system output; that tells you how easy it all was!

And yes, the ASIO is the SoundBlaster’s.

Look forward to getting more ideas!

All the best

Can you take/post screen shots of the Audio Settings in Roon and the Audio settings in Windows. in windows you can you Snipping Tool to do this.

Hi - screenshots attached of the various settings. In Roon, they are identical for each output type on the PC wherever possible. If you need anything specific or else, please let me know and I’ll upload that.

Hi @LowKey — Thank you for your patience and my apologies for the slow response here.

Moving forward, may I kindly ask you to please disable (Sound blaster) via Windows audio settings and make the Realtek the default output device. Confirm that you can successfully playback from another application or media player, then launch Roon. Disable everything in the “audio” tab except for the “system output” and confirm if you can playback.


Hi @Eric - Apologies for the delay in getting back to you on my side. I’ve tried as you suggested, and I get sound from a media player and in the device configuration window, but not using Roon. I have tried setting the volume control to WASAPI and to fixed volume, but still no sound.

Look forward to hearing from you further!


Hi @LowKey ---- No worries. I would like to take a look at your logs to see if we can identify anything obvious that could be causing this to occur.

I will be contacting you via PM momentarily with instructions.


I’ve fixed it with some help from Avast. For anyone else experiencing this, here’s what you need to do:

"First please allow the Roon application in the Avast Firewall application rules:
(set the program to be “always allowed”)

After that please go to the Avast menu - Protection - Firewall - Settings - PREFERENCES and check the “Internet Connection Sharing mode” option.

In the same window, go to the “System rules…” and enable the first two options (Windows File & Printer Sharing and Remote desktop connections).

Finally please restart your computer and try to play the Roon program again."

[I’d done the first but not the second of the suggestions above]

Thanks to @Eric for his patience and help.

1 Like