Roon remote rarely able to connect to core

Core Machine (Operating system/System info/Roon build number)

Windows 7 . HP z820 with 64gb memory
Windows 7 form factor pc with 4gb memory

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear 24port 1gb switch

Description Of Issue


Appreciate any help anyone can offer here. I’m having a helluva time using the Roon remote as I’m rarely able to connect to my core “looking for core” unless I’m standing right in front of my WiFi router, despite being able to access An operational WiFi network everywhere.

Looking for configuration advice so I can configure network/Roon such that I can access core from anywhere I have WiFi connection in my on. Perhaps a static ip or specific range for my core and bridge devices? Looking for help here.

Hardware listed below but basically I have Roon remote on iOS device. My Roon core is connected by Ethernet/lan to a network switch which my router/modem is also directly connected to via Ethernet cable. Bridge that serves music to zones also hardwired to switch. WiFi comes from my router and modem device. How can i configure this such that I don’t have any issues reaching my core via WiFi? Help please! Thank you in advance guys and gals!

Hi @ColdOnes,

What is your model of the router? We have some routers that need special settings applied listed in our
Networking Best Practices Guide.

What I would suggest for you is:

  1. Check your router model to see if it’s on the list and apply the settings

  2. Even if the router is not on the list I would take a look in your router config for any “multicast” settings and make sure that multicast is turned on. IGMP Snooping/Proxying options have helped in the past, so that may also be helpful in trying to toggle.

  3. It sounds like your modem might also be a WiFi access point. Depending on how you have it configured, it is possible that when the iOS device connects to the modem WiFi, it is no longer in the same subnet as the Core (meaning they have different IP address ranges - e.g 192.168.1.XYZ vs 192.168.2.XYZ. To prevent this, I would suggest changing your modem into Bridge Mode and let the router handle all the IP address assignments.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.