Roon remote sluggish connection performance

This has been a issue with Roon remote since forever, Roon remote is having trouble to connect to Roon core, sometimes it works but most of the time the remote connection is unable to connect Roon core. Can’t this be done a bit more flawlessly just like Chromecast or Spotify connect?

I use an Android phone, my roon core is installed on a intel NUC computer, streaming to a raspberry pi. The issue has been the same back in the days when I was running Roon on my iMac and with USB DACs. It seems to be inherent to how Roon handles the network connection to core.

Are there any network settings that I can optimize?

1 Like

Add details of your set up as requested in the support template.

Hello @Philippe_Galowich1,

What does your network setup look like? Can you list the model/manufacturer of your networking gear?

Both Intel NUC and raspberry pi are directly connected via ethernet (cable) to my internet providers box, a Ubee TW620. No router used.

Hi @Philippe_Galowich1,

Thanks for the additional information.

You should be aware that we have often seen ISP-provided routers have a poor implementation of passing multicast traffic (which is what Roon uses for Core/Device discovery).

I can’t say with certainty yet if this is what’s going on regarding this issue, but it is one aspect to be considered. Generally speaking, we have also seen that turning on “Multicast Routing” , “IGMP Proxying” or “IGMP Snooping” in router settings has helped in the past with multicast issues.

You mentioned above that you also have an iMac in your house, does the iMac exhibit the same behavior when you try to connect to your NUC?

The connection from computers to the NUC is reliable, I use both an iMac (via ethernet) and a pc laptop (WiFi) and it works.

Hi @Philippe_Galowich1,

Since this behavior is just impacting your Android remote in that case, I would check the IGMP Snooping/Proxying settings on your router. These specific settings as helped Android connections in the past. You could also try pressing on the “Help” that appears when you can’t find the Core and putting in the IP address of the Core to specify a manual connection or typing in as the IP address.

Thank you. Just an additional question: would an additional dedicated router help?

Hi @Philippe_Galowich1,

Yes, it is very likely that a dedicated router will help. As I mentioned, ISP provided routers often have poor multicast implementations and other, consumer-grade routers have a better implementation.

Even if the router doesn’t help with this issue specifically, using a properly spec’d router will provide a better overall experience for Roon and other communication on this network.

Please see our Networking Best Practices Guide for more information regarding network setup.

Does it mean every time I re-install Roon remote on Android OS I’ve go to help and set

Hi @MusicFidelity,

If your router’s multicast settings are properly configured and working as expected, no you shouldn’t have to do the workaround. This suggestion is for routers which have a poor multicast implementation.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.