Roon Remote unable to connect to Core when MacBook dims

Roon Core Machine

MacBook Pro (15-inch, 2016), 2.9 GHz Quad-Core Intel Core i7, 16 GB 2133 MHz LPDDR3, macOS Monterey 12.6 (21G115)

Networking Gear & Setup Details

AX1500 WiFi 6 Router

Connected Audio Devices


Number of Tracks in Library

750 albums

Description of Issue

After updating all devices to Roon version 2.0 (build 1128), my Roon remotes (iPhone and iPad) are unable to connect to the core when my computer dims (not closed / sleeping / off) with the Roon app still running. Prior, I did not have this issue; I was only able to not connect, as expected, when I closed Roon on my core computer, shut the computer (engaged sleep mode) or turned it off. This has happened consistently, and I am not having any WiFi / connectivity issues while I observe the issue.

Thanks for the help!

I have a similar issue.
I run Roon Bridge on a MacBook and after the display dims Bridge will disconnect. Sometimes.
With Bridge the Mac is behaving as if it’s sleeping after dim but other apps continue to run in the background as expected.
This might not be the solution you’re looking for but the free app Amphetamine resolved this for me.

Thanks for the reply. I’d like to hear from Roon on whether this is an intended change in functionality or if there is something they can fix on their end or that I can troubleshoot on my end, ideally without changing my computer’s power consumption / sleep / dim settings.

@support - help would be much appreciated!

Hi @Paul_Huett,

Thanks for reaching out. I wanted to have you confirm what your settings are under energy saver in system preferences. I don’t use my Mac as a core but have in the past and had to modify the default setting.

Screen Shot 2022-10-04 at 7.23.22 AM

@Wes Thanks for following up. My settings have been as follows:

I’ve been using Roon for close to a year and had never had any issues with the app connecting from my iPhone or iPad after my computer went to sleep until the latest upgrade.

Checking Prevent your Mac from automatically sleeping… does seem to work now to make sure the app can connect at any time, but now my computer will essentially never go to sleep, which is not how I’d like things to work. Is there a way we can get the prior functionality back? This feels like a bug / loss of functionality with the upgrade.

Hi @Paul_Huett,

This is something we’re looking into. As a Mac user, I was personally unaware that Roon could behave this way as it seems contrary to the idea of a core’s main function. Always on and on-demand access to household music.

You’re not the first person to report this though. I can think of at least 3 others offhand.

For now, I will mark your change as a solution but in conversations with others, this will be something we look at in the future.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.