Roon remote won't connect in via ipad, laptop or android

Core Machine (Operating system/System info/Roon build number)

Music only PC with Windows 10 Pro. Intel Core i7-7700.
Roon version 1.7, Build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Music PC connects via wired ethernet to JPLay modified switch D-Link DGS-108.
D-Link connects via wired ethernet to TP-Link TDW9980 (N600 Wireless Dual Band VDSL2).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Music PC connects via wired USB to Audio-GD DI-20HE USB-SPDIF converter.
Audio-GD DI-20HE then outputs via wired AES/EBU to Devialet 400

Description Of Issue

The system above has been working fine for months until last Friday 17.4.20 when I was suddenly unable to connect via Roon Remote on Ipad (Last time I’d used the system successfully had been three days prior). I then tried to connect via Roon remote on a Windows laptop & Android phone (Samsung) but exact same problem occurring.

When I try to use Roon remote on iPad or Android I get the below:

When I select ‘Connect’ I get the Roon logo cycling endlessly on iPad, Android phone and laptop as below:

I’m not knowledgeable at all about computing and/or IT. Having said that to date I’ve tried/checked the below:

Windows 10 is up to date (Version 1909)
iPad up to date (currently on 13.4.1)
Restarted music PC, TP-Link & Switch (more than half a dozen times by now)
Deleted and reinstalled Roon Remote app on iPad (3 x now)
Checked IP addresses : Modem/router address is, Roon Core is, iPad, windows laptop
All devices using same Subnet Mask
Checked Windows Defender Firewall and Roon.exe has green tick

When the Roon logo is cycling on either the iPad or the Android phone and I shut down & restart the Music PC running Roon Core both the iPad & phone ‘see’ the disconnection & reconnection as below:

Having scanned all the help forums I could find (though may well have missed something & apologies if I have) and tried everything I read that seemed related/I could understand I’m now out of ideas.

Would appreciate any help thanks. And again apologies in advance that I have very little in terms of computing knowledge/skills so may need to ask clarifying questions (ironically one of the reasons I bought a lifetime subscription to Roon in the first place).

Turn off windows firewall and any other firewall apps to troubleshoot

A post was split to a new topic: Since the Roon update cannot use Roon anymore from any device

A post was split to a new topic: B536 I am unable to stream to any of the speakers

Hi @Jason_H,

Do you have any additional antivirus application installed (McAFee/Kaspersky/AVG/ect.)? If so, is there any change in behavior if you temporarily disable these? If you are able to connect after disabling them, you will need to set proper exceptions in the antivirus software.

I know you mentioned you have checked Windows Defender, but it may be worth a try to re-add the Roon exceptions regardless to see if that helps:

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Thanks for your suggestions noris.

Firstly I don’t have any other firewall or antivirus software installed.

I’ve then tried to follow your suggestions, first by checking I’m on a Private network, and then by disabling Windows Defender, as per the first two images below, but still no luck then connecting Roon Remote through any of my devices I’m afraid. Please let me know if I’ve done something wrong - I’ve included the images to help as I don’t always know enough to be confident I’m accurately following written instructions.

When I then tried restarting the Core after disabling the firewall I got the iPad showing a message saying something along the lines of “The new version of Roon you installed may require a database update. This may take longer than usual” (I neglected to take a screenshot of this).

After the update message I then got the following image on the iPad showing Roon build 536

But again I can’t connect via Roon Remotes oniPad, Android phone, or Windows laptop. Same endless cycling of Roon logo.

I’ve also included below an image of my Firewall rules in the hope that might shed some light (though as far as I know it’s still turned off).

Appreciate any further suggestions you can offer.

And just an extra note. When Windows Defender Firewall was on these are how my allowed exceptions looked:

Hi @Jason_H,

I would suggest you remove the existing RAATServer, Roon and RoonApplicance entries and re-add them to your Windows Defender Firewall.

In the past I have seen reports of Windows Firewall get confused when Roon is updated and might think that the previous entries refer to another .exe instead of the updated .exe

Thanks noris, I’ll give that a try. And apologies for the NOOB question (a term I picked up from the Roon community here & which is entirely apt in my case - if nothing else my current difficulties with Roon has furthered my computing understanding a little, though not having music during the COVID19 lockdown is a definite downside), but when you say “remove and re-add” the RAATServer, Roon, and RoonAppliance entries, can you explain how I do that? Do you mean simply untick and then re-tick them? Or do I need to delete somehow and then re-add?

Also, does the current Firewall configuration where I have 3 x raatserver.exe entries, two ticked under Private & one under Public, and also 2 x roonappliance.exe entries, with one tick in each Private & Public, look correct to you? Thanks

This is what Noris means to delete all and then add again - but maybe just turn off the firewall first to troubleshoot.

If you click on “Change Settings” and then highlight Roon.exe/RAATServer.exe/RoonApplicance.exe and click the Remove button next to details, it should remove those entries.

I would manually re-add them back afterwards:

Thanks wizard. I’d seen your earlier advice to do that and tried turning firewall off completely (as per image 6 above) but unfortunately it didn’t make any difference in the ability of any remotes to connect. I’ve just tried turning off the firewall again (including a pc restart for good measure) and again no luck. Roon logo cycles endlessly.

I’ve presumed that if a firewall setting was the issue here then turning the firewall off completely would illustrate that, and the next step of deleting and re-adding exceptions for Roon would be a potential resolution only if turning off the firewall completely resulted in successful connection by the remotes.

Despite that not having occurred I’ll try deleting and adding exceptions for Roon again as best I can and report back. Thanks.

Ok, as per your suggestion noris I’ve turned the Firewall on again and deleted the entries for the three Roon components. I’ve then attempted to add them back in manually. Took me a bit of time as I could see them via your Database Location instructions (using %localappdata% in Explorer) but when I browsed for them in Defender they weren’t appearing. A Google search about how to show hidden files seemed to help. That allowed me to find them in Defender via the pathway shown below:

Giving each permission in Defender Firewall I now have this:

And my Inbound Rules in Defender looks like this:

Unfortunately none of the above has made any difference to the original problem.

Via both the iPad and Android phone I get this (now build 537):

And when I select Connect again, Roon logo endlessly cycling.

I’ve tried to describe my steps in as much detail as possible as it’s very likely I could have done something wrong, so please let me know if that’s the case.

Otherwise…still no music… Help!

In lieu of no recent suggestions I’ve (nervously) completed an uninstall and reinstall of Roon. Unfortunately that’s had no effect at all on the problems described above.

I’ve also tried downloading and playing music through the Tidal app for Windows which works just fine, indicating to me there are no general problems with connectivity within the rest of my stereo system.

Hi @Jason_H,

How did you perform the reinstall of Roon? I would suggest performing a reinstall using the following instructions to set the old database aside:

  • Make a Backup of your current Roon Database from the Core
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App to generate a new Roon folder
  • When prompted by Windows Firewall, make sure to add the exceptions
  • Verify if the issue is resolved
  • After verifying if the issue is resolved, you can restore from the backup you made in step #1

A post was split to a new topic: Can’t connect to ROCK Core

6 posts were split to a new topic: No Endpoints/Tracks/Music

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.