Roon remotes can't see Core (CentOS)


I have an small PC running linux (centos) running roon server and I’ve installed the roon client on a windows box. The two can’t seem to see each other. I’m using ssh between the two machines, so I know the network config is ok. One search result says I need to tell the roon server to accept remote connections, but they describe using UI to do it and I’ve got no UI until I get the client to connect. I see there are settings files stored in a Settings dir on the server - is there a file I could create to enable the remote connections? Other tips for making this work? I’ve disable SELinux on the server box, but that didn’t help. There’s no firewall between the two - just a asus router (with multicast enabled).

The debugging info exposed to the user is pretty limited…

roon server is v1.5 (build 363)
Running on a i3-8109U with 32G ram
Music isn’t stored anywhere - it’s my first time trying to get the server running/configured

Connecting to it through an Asus RT-AC1750.

Running the Roon client on a Windows 7 Pro 64-bit box. I can’t tell you the version of the client as it gives very limited UI. I downloaded it today 1/21/19.

Thanks for any help.

Possibly your Windows system has a firewall blocking certain access, eg, from Roon server on the Linux box. Check the thread at Roon doesn't find Dragonfly Red on one of my desktops.

Which software have you installed on the windows machine? You need to configure Roon to see endpoints and the server from the remote software. This can be on ipad/tablet or desktop pc. When run for the first to it will ask you to connect to a roon core and show you possible ones from the network or you enter the IP address manually. Once connected you configure the servet to see emthe clients in settings/audio you should see the pc running Windows in there.

That’s not necessarily true. Roon uses multiple things (other ports, multicast) which SSH does not.

True - I meant the machines can reach each other, at least for some types of packets.

If Roon needs special access modes, is there a list of the requirements? I’m not running a super locked down network and there’s just one router between them.

Typically, turn off IGMP snooping in the router. Make sure multicast is enabled on both machines. Check the CentOS firewall logs to see if it’s rejecting connections from the Windows machine to ports in the 91xx range.

I installed the “Common Roon Downloads” all-in-one from think link here:

It tries to connect to the roon core, but sits scanning forever. In the help you can give an IP address and that didn’t seem to do anything either.

Then you have a network discovery issue of some kind. These can be caused by firewall or router/network configuration. Some ideas of what your network setup is with help with working out the issue. So list your kit and how they all connect together. Do both server and pc have IP addresses in the same range. Make sure the firewalls on both computers are allowing all Rooms services through.

Hello @Robert_Greenwalt,

Has Roon been added as an exception to your Windows Firewall? You can use these instructions to check:

Also, have you made sure to install all of the needed dependencies for Linux? You can use these instructions to check.