Roon Remotes lose connection to Roon Core

Hello @support

I have installed Roon Core on one laptop and 3 Roon remotes which installed on iPhone, iPad and another laptop.
iOS Remotes are constantly losing connection with Core (wi-fi connection). Remote on laptop works stably (wire connection)
When it happened music continues to play.
My network topology is:

  1. Router ASUS AC750 (RT-AC51U)
  2. Laptop Dell E7240 16Gb RAM, SSD, i5, WIN10Pro x64 (Roon Core) - has a wired connection 6cat to ASUS
  3. Laptop Dell E6320 8Gb RAM, SSD, WIN10Pro x64 (Roon Remote) - has a wired connection to ASUS
  4. dCS Network Bridge - has a wired connection 6cat to ASUS
  5. iPhone 6s and iPad Air - have wireless connection to ASUS (for other applications they have good performance without drops etc.)
  6. NAS WD My Cloud with library (file storage) - has a wired connection to ASUS
  7. All devices are have installed latest updates

I tried to
Disable Windows Firewall and Defender on Roon Core laptop.
Reboot all devices
Reinstall Roon remotes on iOS devices

But nothing help me…

Hey @arzojaan — I appreciate you reaching out, and apologies for the difficulties here!

To start, can you please confirm that your iPad and iPhones remotes are in the same IP range as your core machine. You can try and app like FING to scan your network looking for devices that it can see with itself showing up in the process. If you are going to give this a shot, please make sure your Roon core is active, as well as both of your remotes

Additionally, so we can further understand what you’re experiencing here, if you connect the laptop remote via WiFi instead of Ethernet do you see the same problem start occurring with the laptop?


1 Like

Hi @dylan

Yes, all devices are in the same network
iPad and iPhone (both upgraded to iOS 12.0.1) see and connected to Core. But connection not stable and refreshed every 1,2,3 etc minutes

If using not-Roon Core laptop as remote via wifi all works without any drops or disconnects.

I have added to reservation all Roon devices IPs by mask on the router. Now started all three remotes. Will be monitor the issue and let you know …

Seems to me that IP’s reservation help to resolve the issue. All remotes are stable more than 1 hour :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @support

I’m here again

Problem returned after a while. it worked fine a few days.

There were no changes with the equipment. Just turned on / off the laptop several times.
Checked the reservation on the router, everything is ok. Device IPs have not changed also. Problem exists only for iOS remotes.

Anybody here ? :thinking:

Hey @arzojaan,

My sincere apologies for the delay here!

Just to verify, the laptop remote is still working when the iPad and iPhone get into this state, correct?

When one of the iOS devices loses it’s connection do they both lost connection, or is one sometimes able to connect while the other one cannot? What is the message that displays when the device is unable to connect?


Hi @dylan

Yes, laptop working without any drops etc (via Wi-Fi)
Yes, one is sometimes able to connect while the other one cannot

I recorded a video with issue on iPhone (iPad behaves similarly)

A post was split to a new topic: Remote connection issues