Roon remotes will not connect to Nucleus

Hi Roon @support

I have some issues/problem Starting up Roon on my Nucleus after upgrading to 1.7.

I’ve the same problem regardless using different platforms/OS client/remote.

The Nucleus is connected directly to Router and I’ve a fast net (100Gb).

I can connect and do/activate all items on the Browser page.

I’ve reinstalled OS and restarted Server Software several times from the Browser Page.

Starting client/remote app I can see my Nucleus and it’s Ready but after connecting to it the Roon symbol just “tugging” along until it’s timing out and ask me to connect to different one.

Same thing all the time.

From my previous mappings I can access Data and its subfolders on the Nucleus and see all my music in Storage.

I have screen prints in pdf’s to send if you give me a valid mail address.

Any qlue?

PLS come back with action plan.

Thanks in advance.

Hi @Lars_Mansson,

Can you share the screenshots here via a shared Dropbox link or another file sharing service?

Since experiencing this issue have you tried rebooting your router, the Core, and remote devices?

Hi again @support

Naturally have I restarted Router and Apps & Win/MAC programs, no change.

Here Comes the link:

PLS notify me if the link don’t work.

Hi @Lars_Mansson,

Thanks for sharing the screenshot of the web UI. There are a couple things I notice here:

  • RoonServer was only running for 38 seconds. Was this right after a reboot? Is RoonServer staying running for long periods of time or is it frequently restarting without any input from you?
  • The version of RoonServer you’re running is 505, which isn’t quite up to date. Can you confirm which version of Roon your remotes are running? You can find this by going to Settings > About.

Hi @support
The ScreenShot was probably taken rater soon after Nucleus Restart, that’s the reason for 38 sec.
As I’ve said before I’ve reinstalled OS (several times) and restarted Server and that is what I got.
When you are talking about Operating system on the Nucleus Browser Page do you mean the underlying Linux OS?
All Remotes are running 1.7 (511).
Why the Nucleus don’t get (511) I can’t understand.
I’ve moved my Nucleus to another fast network with the same result.
This to exclude the eventualities of network issues.
My Nucleus is now put in “quarantine” and I’m now running my Lic. on my Mac Mini (works OK).
But naturally I will use my Nucleus when it’s healthy again.

Hi @Lars_Mansson,

I see that you restarted RoonServer, but it looks like the OS has been running quite a bit longer. Have you tried rebooting the entire device, and not just RoonServer?

You can do this by clicking the Red button in the upper-right and choose Reboot:


Typically a reboot will help the update process if it’s stuck, so it would be a good idea to give this a try as well.

Hi Dylan @support
I’ve now put Nucleus back on the net.
After restart of the device I Reinstalled OS again and Rebooted.
After unit was back on line I checked the Browser Page and this is what I got:
Operating System
Version 1.0 (build 183) stable
Running 7 minutes, 43 seconds.

Roon Server Software
Version 1.7 (build 511) stable
Running 1 minute, 47 seconds.

Still the same Problem!!

Thanks, @Lars_Mansson.

The fact that the Nucleus was able to connect to the network and update RoonServer is definitely a good sign, at least. While the issue still persists, getting the Nucleus on the same update version as the other devices is a great start.

Moving forward, here’s what I’d like to suggest:

  • Rebooting the Core machine from the web UI
  • Rebooting the remote
  • Try to connect from one of the remotes — Make a note of the time you click connect and which remote you are using

Once you do the above please provide the time in your local timezone that you click connect as well as the remote you’re using. We will then enable diagnostics and take a look at what occurred during that time.


Hi Again @support
Hard Reset of Nuc (power off) then after unit online logged in on Web UI.
Rebooted from Web UI.
Using Ipad Remote 1.7, tried to Connect (Nucleus was ready)
After 90sec Timeout screen came back.
Did a reselect of Nuc but now Nuc is jumping from “initiaizing”, “connecting”, “Last seen 1 min” then Ready.
Reopend Web UI and found that Server Software had restarted by itself.
Looking at the iPad Remote you can see that Nuc is randomly restarting the Server displaying the above message.
If you look at the reloaded Web UI at the same time you will see that Server Software “Not Started”.
Any clue?

Hi @Lars_Mansson,

It sounds like RoonServer might be crashing when the remote is trying to connect. I’ve enabled diagnostics so the team can take a look — Do you know what time in your local timezone the above test was performed?

Hi @support
I’ve monitored the Web UI (by doing repeated reload) at the same time I see the Nuc is jumping from “initiaizing”, “connecting”, “Last seen 1 min” then Ready on the remote connection screen.
It’s during that time that the above messages appear that you see Server Software “Not Started” popping up then normal again when remote connection screen shows Ready.
Sorry, but I don’t understand what you mean by: “Do you know what time in your local timezone the above test was performed?”

Hi @Lars_Mansson,

What I’m looking for here is the time that the issue occurred. For example, 4:57 PM EST — This timestamp helps the team analyze the diagnostics report so we can better understand what is happening exactly as the issue occurred.

Hi @support

I’ve added 2 mov in my dropbox.( that you got before )
Hopefully they will show some light on my problem together with my prev comments.

Thanks, @Lars_Mansson. Would you kindly once more use the directions found here and send us over a set of logs using a shared Dropbox link so we can take a look now that everything is updated?

OK Logs are in Dropbox

Thanks, @Lars_Mansson — I’ll get this to the team for further analysis.

Hi @support

Can you give me any progress report on my case?

Hi @Lars_Mansson,

I just wanted to let you know that I have a meeting scheduled with our senior team this week to discuss this and I’ll be sure to update you as soon as we have more feedback for you. Apologies for the wait!

Hi @Support
In reference to your mail above.
Any News ?

Hi @Lars_Mansson,

Apologies for the delay on this one. The team has been trying to run some additional diagnostics on your device but it appears to not be reachable to our servers.

Since these diagnostics can’t be run, we are hoping you might be able to send over logs once more so we can review another set of data on this. The logs that were sent before were RAATServer logs, which contain some information, but not everything that our diagnostics would be able to tell us. Can you send us RoonServer logs so we can review them?

In addition to this, it’s possible that this issue lies in the communication between the remote and the Core over the network. As a test, can you try running your Roon Core from another machine? Do remotes connect okay?