Roon Remotes Will Not Connect to Roon Core

I install Roon updates as notifications appear on my devices. Since I installed the most recent Roon update cycle (which for me occurred in the last few days) Roon Remote and Roon Core software on our end user devices cannot connect to the Roon Core. I have verified that the Netgear Orbi network devices are all running the latest firmware. I have made sure that the SonicTransporter software is up to date, and re-started the SonicTransporter. I have cleared the cache bin the Roon Server and re-started the Roon Server (Roon Core). I have made sure (with the help of Netgear product support) that the network is functioning correctly. Please note the Application listing for Remote 1 (Mac Pro), below. This implies that the update process did not successfully update from Roon 1.0 to Roon 2.0 on our remotes. Needless to say I am not getting any update notifications when I launch a Roon Remote.

I have tried to enter the IP address of the Roon Core in the Roon Remote software, so that Roon Remote knows where to look - to no avail.

Describe Your Setup

  • Core machine: Small Green Computer SonicTransporter i7, OS 2.8, 8 GB RAM, 2 TB SSD, Roon build = Version 2.0, Build 1143.

Sonore Ultra Rendu, OS 2.8.

  • Details on your Remote(s)

Remote 1: Mac Pro 2013, 6 core Intel Xeon, 64 GB RAM, 1 TB SSD, macOS Monterey 12.6
Remote 2: MacBook Pro 2019 Laptop, Intel i9, 64 GB RAM, 2 TB HD, macOS Monterey 12.6
Remote 3: iPhone 11 Pro, iOS 15.7.1
Remote 4: iPad Pro, iPad OS 15.7.1
Remote 5: MacBook Pro 2022, M2, macOS Monterey 12.6.1
Remote 6: iPhone 13, iOS 15.7.1
Remote 7: iPad OS 15.7.1

I have checked the Applications on my Mac Pro (Remote 1, above) and found the following:

Roon:

Version: 1.0
Obtained from: Identified Developer
Last Modified: 10/28/22, 2:50 PM
Kind: Universal
Signed by: Developer ID Application: Roon Labs LLC (WU8DGC424P), Developer ID Certification Authority, Apple Root CA
Location: /Applications/Roon.app
Get Info String: Copyright © 2016 Roon Labs LLC

  • Networking Devices
    Netgear Orbi RBR750 Router (latest firmware)
    Netgear Orbi RBS 750 Satellite (latest firmware)
    Router and Satellite are hard-wire connected using Ethernet. I tested the network functionality in depth with Netgear tech support yesterday (Oct 31, 2022).

Netgear 8-port passive switch connects to Satellite via Ethernet cable (both Sonore Ultra Rendu and Music Server connect to this switch).

Note: Wi-fi networking is not part of the signal chain for the core of the music system, other than to allow Roon Remotes to connect to Roon Core in order to play music. The SonicTransporter, Sonore Ultra Rendu, and Lyngdorf digital amplifier are all connected via Ethernet cabling.

  • Audio devices in use
    Sonore Systems Ultra Rendu Network Player also running OS 2.8 (like SonicTransporter)
    Lyngdorf TDAI 2170 digital amplifier
    Sonus faber Cremona Auditor M version 2 speakers

I also have a Moon CD player outside the audio chain of the music server playback system - this also works fine.

  • Library details
    I have subscriptions to both Qobuz and Tidal. My library on the SonicTransporter is as follows:
    Roon Server Database Size: 1.5G
    Roon Server Cache Size: 1.4G

I have about 6,500 albums in my library, of which half (3,200) are digital audio album files of one kind or another ranging from 44.1/16 to 192/24 and various flavors of DSD. I cannot remember how many tracks are in my library as I would need to fix this issue where Roon Remotes are not communicating with the Roon Core in order to see that.

1 Like

Hi @Michael_Bade,

Could you confirm that your Roon Remotes also running Roon 2.0? (Roon 1.8 is not compatible with 2.0.)

I suspect something went sideways in the update process. I clicked on the ‘Update All Devices’ button in the Update Roon banner several times. However, I checked my Mac Pro and it’s running Roon 1.X

I just went to the Roon downloads page, downloaded a fresh copy of Roon for MacOS to run on my Mac Pro, installed it, and no change - it will not connect to the core. Also, it is called Roon 1.0 in ‘Get Info’.

Can you provide any additional information on your network? This may be an addressing issue. Also, have you rebooted your SGC Core and all of your Remotes and your Orbi router?

What kind of info are you looking for? Also, please note that I have put the exact IP address for the Roon Core into the Roon Remote software and it STILL doesn’t see it.

I have rebooted the Roon Core and the Roon Server titself numerous times. I have rebooted the Orbi Satellite but not the Router. I will reboot the Router tomorrow and report back.

Thank you Michael, can you post a screenshot of what you see in “Get Info”?

Additionally, what are the IP addresses of your Core and Remotes? I’m wondering if they all are on the same network subnet.

All remotes, the Core, and everything else on our little home network is on the same subnet. IP addressses 10.0.0.X to 10.0.0.XX sequentially. There are only 14 devices. Here’s the screenshot of what appears for Roon in my Applications folder.

Hi @Michael_Bade,

I’m not a Mac user but am assuming that the “Get Info” is similar to “Properties” on Windows.
This is what I see on my system that is running Roon 2.0 and I too see it is reporting 1.0.0.0 … I suspect Roon are not maintaining this information (@support please note) and it’s a false flag.

image

May I suggest the following which will confirm what versions is running …

Run Roon and then from the Roon main menu … select settings → about,
you should see a screen similar to this example below.

image

You will note my system is running Roon 2.0 for both the Core and the remote.

Can you perform this and capture what version of Roon is running on each of your devices.

Thanks, Carl - you are right, ‘Get Info’ on the Mac is the same as ‘Properties’ in Windows. Under better circumstances I could check the version installed through ‘About Roon’ in the Roon app, but I cannot do that because (under present circumstances on my computer) as long as Roon is trying to connect to the Roon Core, ‘About Roon’ is not available. My current situation is that as long as the process of trying to connect to the Core is underway, every other process is put on hold. This has to be regarded as an architectural flaw - the process of connecting should not interrupt something as innocuous as checking the Roon version.

In any event, I reinstalled Roon on my Mac Pro yesterday, so I should have the latest build. The version of Roon on my Mac Pro is the latest version distributed off the Roon website, and it still cannot connect to the Core.

Good point :frowning:

Agreed.

I’m now of opinion that something is amiss with Roon Server on the SonicTransporter …
Let me tag @agillis at Small Green Computer to see what advice he can add.

I have it on my list for today to contact Andrew. I found in a different posting in this community a comment he made to the effect that re-installing Roon Server solves most Roon problems… I will need his help and advice to do it right.

Carl, thanks for your interest and help!

1 Like

You’re very welcome, let me know how it goes with Andrew.

Andrew reached out - somehow the box ‘Enable local playback to a USB DAC or HDMI audio device with Roon Server’ in the Roon Server menu had been checked. I unchecked it, which re-started Roon Server, and everything came back up. So yes, I am running the latest software on my devices - all Roon 2.0 Build 1143.

Again, thanks for your help and support!

3 Likes

Excellent news and great service from Andrew / @agillis.

Good you got it working! To anybody else reading this check out the sonicorbiter.com FAQ. There are fixes for all common Roon and non Roon problems you can experience with the sonicTransporter.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.