Roon repeatedly crashing

I have a Nucleus+ (Rev B) that worked flawlessly from January until this week - now every time I try to play anything, the control point loses connection and it struggles to reconnect to the Core. When it eventually does reconnect, it has logged me out of Qobuz and I have to ‘retry’ to log back in.

All my music is stored on a QNAP TS473A, my network is completely stable and none of these issues were happening before build 913 was automatically installed. I have the same issue with control points used on my iMac (24 inch M1), my iPad Pro, my iPad mini, and my iPhone X.

It seems from posts on the Forum that several people are having similar issues.

Quick follow up: have just uploaded build 918 and the exact same thing is still happening.

I am having the exact same problem: Roon Nucleus+ (Rev B), had been working fine since January, but all of a sudden (in the last couple of days) is crashing almost immediately when I select anything to play. All my music files are stored on a NAS, and the set up had been rock solid before now. There have been no other changes to my network.
I can access the Web interface, and all appears to be as it should - but whenever I try to use a control point (via an iMac, iPhone or iPad) it says after a few seconds ‘Lost connection!’.


Hi - I would suggest you start a thread here in Nucleus support so they see another user having the same issues. They may want to look at your logs as well to try to ascertain what is happening.

1 Like

Hi @Paul_Heywood ,

I’ve activated diagnostics on your Nucleus and your logs appear to be a bit different than @Wayne_Carter , it appears you are running out of File Handles, while Wayne was running out of memory.

Can you please confirm that the issue also occurs if you disable your Roon Settings → Storage locations? If it does then it would be helpful to have your database for testing in-house, please confirm this first and then use these instructions to upload the database to the folder below and let us know once complete, thank you!

Thanks for this. If I disable Storage locations, then the problem goes away. In fact, the problem seems to occur only when Roon is actually scanning the storage location. It was set (by default?) to do so every hour, so I changed it earlier today to scan only on startup. After that, things were ok - but when I rebooted the Nucleus+ and it therefore started scanning again, then Roon Server crashed immediately when I tried to play anything.

Is there a fix for this? It had not happened previously.

Follow-up: having reset scanning to only on start-up, all had been working well today until I added an album from Qobuz to my library, at which point Roon Server crashed again. Not sure what you mean when you say I am ‘running out of File Handles’, but would that be consistent with this?

I uploaded the database to the folder, as requested.

So I reset everything to factory defaults and started again from scratch. Allowed Roon to finish scanning files on my QNAP, set the rescan interval to 24 hours and all was fine - until the rescan started 24 hours later, at which point Roon Server promptly crashed and I had to disable the scanning to get it back.

There is clearly some kind of fault here, which must be related to the scanning process.

This had not happened before this week, and it makes Roon much less useful. If I disable the scanning process, I have no access to my music on the QNAP. I could set the scanning to ‘only on startup’, but then I need to wait for the scan to finish before I can use it. Alternatively, I guess I could wait up and set the scan to take place every 24 hours in middle of the night - but that is hardly appropriate to get an expensive piece of kit to function satisfactorily.

It would be really good if you could get to the bottom of this: not being able to rescan without Roon Server crashing is a pretty fundamental flaw.

Hello @Paul_Heywood ,

Our recent Roon release addressed an issue that looked similar to your issue, but I’ve just looked over logs from your Nucleus and I see that it hasn’t helped, you are still getting some issues here.

The log shows that the last scanned folder is the following: @Recently-Snapshot/GMT-00_2022-03-28_0100/Contemporary - Country, Folk & Folk-Rock/Pete Seeger/

Can you try to move this folder out of your storage location and see if that helps? I also wonder if the @ in the folder name might be part of the issue.

Many thanks for this update. Yes, I can see that if Roon is scanning the @Recently-Snapshot folder, then that could create a problem with duplicate files.

However, it seems the folder is automatically generated by the QNAP operating system. There is an option to make it not visible in the Multimedia folder, so I have enabled that. I hope that will stop Roon scanning the folder, though I am not sure if making it ‘not visible’ removes it from the scanning process or not (i.e. it may be ‘not visible’, but still there).

Are there other folk out there using QTS 5.0 on a QNAP who have had similar issues?

1 Like

A post was split to a new topic: Roon just shuts down after 10-15 minutes

This topic was automatically closed after 45 days. New replies are no longer allowed.