Roon Restart Casing 100% CPU Utilization

Core Machine

Windows 10
Core i9-10900K CPU
NVME boot drive
Files on QNAP NAS
10Gbit Ethernet on Roon server and NAS and network.

Network Details

Ubiquiti 10 Gbit, all wired

Audio Devices

All kinds

Description of Issue

When I reboot my PC or just restart Roon, it pegs my CPU at 100% for around 10 minutes causing audio to playback choppy. The rescanning of the network drives appears to be causing this. This seems like a new issue I haven’t experienced in the past.

1 Like

Weird, it is possible to throttle the analysis on the library settings page, but I’m not sure that’s going to help here unless it’s set up to take all cores on fast, and it’s probably not news to you.

I don’t think it’s doing analysis on the startup scan every time is it?

I’d agree it’s not likely, but given its about the only control over processes Roon affords it’s worth a shot is all.

It is not doing audio analysis, but, it is doing a full library scan every time it starts up.

I’m a bit curious where your files are located? Are they on the same machine that hosts the Roon Server, or is that a “mapped network drive”?

You are obviously running Win 10 and looking at the Network part of the status monitor it seems that network traffic is quite heavy.

I’d say that this behaviour is pretty normal though, with your extensive library and powerful machine.

How many cores are dedicated to audio analysis in settings? Unless files are “touched” by external processes there should not be any reason for Roon to re-do the analysis though.

1 Like

Nice observation on the network activity, that’s interesting. Functions like watching a folder or detecting whether a file has “changed” aren’t as well behaved for network storage. Could it be that something has changed in the setup that has Roon thinking it has to analyse some/all of the library as changed?

Put another way, with all that CPU/network activity the obvious conclusion is that reanalysis is the issue. Presumably the log file will record the analysis if it’s happening?

@ComputerAudiophile you also should be mapped to an SMB share entry not a mapped windows drive letter. Not sure if this makes any difference but its the way roon expects to access a networked Sharepoint.

Do you have a link to the documentation about this?

It isn’t analyzing the music though. That takes many days to complete. This current process takes about ten minutes, during which Roon isn’t usable.

This is a fairly new thing.

To add network storage, we recommend using your NAS drive’s hostname, such as \DISKSTATION or smb://MyNASDrive . You can usually find this information by logging into your NAS, and examples are below. You can also use your NAS drive’s IP address, but note that this can change, depending on your network’s settings.

A large collection on a NAS will take much longer than local drive in the Core machine…I use a 16TB internal drive and use the NAS as a backup location for the Music. 13TB worth…270,000 tracks.

I don’t think that says what you think it says. It say use a name rather than IP address. It doesn’t say anything about mapped drives. Mapped drives to the host name are no different.

It was and has always been my understanding of using Windows and NAS/Networked drives that they should be added as a network share in the storage settings. Im sure this was the case in the old KB pages but I cant find the explicit reference. I’ve been around this forum for many years (like you) and its always been the way that was dictated for windows setups.

I’m sure support guts will turn up here soon enough and advise one way or the other.

Hello @ComputerAudiophile,

I am so sorry we’ve missed this post for so long. Please accept my sincere apology :pleading_face:

I was wondering if your CPU is still as high when you first turn on Roon and your network drives are rescanning? We’d love to help if there’s anything we can do :nerd_face:

Here is a guy with similar issues.

I think I also have a similar issue but not as heavy. After restarting my Sonictransporter i5, I can’t access Roon from my iPad immediately. Local music is stored on a Qnap.

Is this something the Roon team can look into ? Can you try and create the issue in your environment maybe ?

@ComputerAudiophile Logs should give us a clear picture of what’s going on. Can you restart Roon and report back here with the local time & date that your CPU gets to 100%? I’ll enable diagnostics and have our team take a look.

1 Like