Roon Rock and Remote install problems

Installation of Roon remote on my laptop to operate the Rock RoonServer installation on my Intel NUC has encountered a problem.

  • The installation is using the latest software downloads from Roon. The laptop is the latest Dell XPS running Windows 10 64-bit. It successfully can access the Rock UI wirelessly including the Data Storage file where the music is stored on the NUC’s internal hard drive storage The Rock output is connected to a dCS Bridge through the NUC Ethernet port. Everything about the Rock installation appears to be correct and fully functioning.

  • The specific difficulty is encountered when I attempt to open the Roon software on the laptop. Although the software correctly identifies the core installation on the NUC, it will not open because when asked to provide the email address and password for the associated (trial) account, it fails suggesting there is a “network problem.” The same error message appears when using the “forgot password” link. I have already tried reinstalling the Roon software on the laptop without any further success, and have also turned off the Windows firewall. Because the laptop is accessing the NUC as well as the internet through the home’s wireless network connection with success, there appears to be an issue with the Roon software functioning as the remote controller of the NUC. Any suggestions how to achieve a successful install would be greatly appreciated.

Flagging @support.

Hi @Craig_Cannizzo ----- Thank you for the report and sharing your feedback with us, sorry to hear of the troubles here.

Moving forward, to help aide in our evaluation of this behavior you are reporting with the mentioned Roon remote (i.e the Dell XPS) would you kindly provide me with the following information:

  • If you have any other active remote devices can you verify for me if they are exhibiting this behavior? My assumption is “yes” but, please confirm.

  • Please confirm that no other device is trying to act as the Roon core and everything has been set to act a remote with the NUC (hosting ROCK) acting your core machine.

  • Are you able to access the NUC via the OS on the Dell XPS without issue?

-Eric

In response:

  • There are not other active remote devices. Assumed that attempting to try other devices for remote control of the core would only make things more complicated, am willing to try any means to sort the problem out if directed.

  • No other device is trying to act as Roon core. The installation on the laptop was solely for remote control of the Roon core on the Rock/NUC.

  • Yes, the laptop Windows 10 OS does have access to the Rock Data file on the NUC where some music has been moved via drag/drop file exchange, only.

Thank you for touching base and taking the time to provide the requested feedback, @Craig_Cannizzo. Very appreciated!

I have went ahead and enabled diagnostics on your account and what this action will do is the next time ROCK is active on your NUC a diagnostics report will be automatically generate/upload to our servers. While my feeling is that this behavior is related to how Roon is currently configured having the mentioned diagnostics report will allow our techs to identify any errors they may see in the attached Roon logs.

In the meantime, was your Roon core hosted on another device by chance in the past or has the core always been the NUC hosting ROCK? If this happens to be the case how did you go about migrating to ROCK?

Additionally, you mentioned that you disabled the Windows firewall on the laptop, can you confirm that there are also no antivirus applications running on the device as well?

-Eric

UPDATE: As per the request of our tech team would you kindly also provide a screenshot of the error message mentioned in your first post (i.e "…it fails suggesting there is a “network problem.”)

In response:

  • The Roon core has only been hosted by the NUC.

  • There is no active firewall or anti-virus application on the laptop. However there has been a change in the internal wireless home network–for the better. Our previous Apple-based Extreme router has been replaced with a Linksys WRT 1900 ACS which for the first time has active firewall which can be disabled or otherwise managed.

  • I will log into Roon this evening when I am back at the house, and look forward to the diagnostics report and further direction as to the Roon configuration.

-Craig