Roon Rock Can't Enable USB DAC

I just installed ROCK on an i5 Intel NUC. I closely followed the install directions (updated BIOs, changed BIOs settings, etc) and the install appeared to go smoothly.

However, when I try to add my USB DAC as an output it gets stuck in Enabling. I’ve found another thread with this issue, but for them it seemed to resolve itself when reinstalling. I’d like to avoid going through the install procedure again if possible.

Are there any troubleshooting steps I can take here?


What usb dac are you trying to add?

Thanks for sharing your report with us, @androidroonuser!

In order to get a better idea of what may be happening here, may I ask that you please answer the following:

  • What kind of DAC are you having trouble enabling?
  • Have you tried rebooting the Core machine?
  • Are you able to enable other zones without issue?
  • Are you able to enable this zone on other machines?


It’s a NAD D-3020 DAC. I’ve tried rebooting the Core machine multiple times, but no luck fixing the issue. I was able to enable an Apple TV and the remote as an output.

Previously, I had Roon server on an Ubuntu server (on the same Intel NUC) and was able to use the DAC without issues. It seems to be a problem specifically with ROCK.

Thanks for the details, @androidroonuser!

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


I ended up going the route of adding a raspberry pi I had laying around as a RoPieee Roon Bridge. I added that to my output source without problems. You can consider this issue closed for me, but feel free to dig into my diagnostics to see if this is a bug that could impact more users. Thanks!

1 Like