Roon Rock Disk Image file - advice needed

Hi,
I am expecting my NUC to arrive early next week and have downloaded the Roon Rock Disk Image file and attempted to create the USB Rock Installation Flash drive using a 32Gb Toshiba USB drive in preparation for the installation when the NUC arrives.

I successfully downloaded and uncompressed the image file and used Etcher (on my Windows 10 laptop) to create the Flash drive. The drive appeared to be created successfully, but following the validation process Etcher reported that the drive had not been successfully validated. I think the message was something like “1 invalid device”.

Has anyone experienced this issue when attempting to create the installation Flash drive? I went through the process a second time, including a fresh download just in case the first file was corrupt, but had exactly the same end result. The creation appeared to work but validation reported the same problem.

I assume this is a problem, and if so does anyone have any advice? Thanks.

Try a different drive, sounds like it is corrupted.

Had it with SD cards but not usb sticks

I have broken ones (corrupted sounded fancier). But not often I have to say.

Yeah, I got the same result from Etcher when writing to a USB stick.

I downloaded the image again and then Etcher was successful.

Yeah, its a problem the machine will not find what it needs to boot.

Try another download until it works.

Just tried again with a different USB drive (different make), but with exactly the same result.

By the way - is it necessary to ‘unzip’ the compressed image file before using Etcher to write the install image to the USB drive or can Etcher cope with just the compressed file. I have tried using both the compressed and uncompressed file but with the same result.

By the way, just after the validation part of the process begins, Windows displays a message of “this drive needs to be formatted before it can be used”. I take it that this is to be expected because a Linux (or Roon Rock version of Linux) partition has been created on the drive?

Just downloaded another copy of the Rock image file (for the 3rd time), ‘cleaned’ and reformatted one of the USB flash drives I had used earlier and tried again.

This time validation was successful.

No real idea what caused the earlier failures, but I guess I now have an USB Installation drive that I will be able to use to install Roon Rock on my NUC when it arrives.

Thanks for the replies.

1 Like

The windows message is usual and you are right to ignore it. Success though! Great.

Have now installed Roon Rock on my NUC and have directed Roon to the Music folder on my NAS.

However, the one thing I have to do is download missing codecs, and am having a bit of a problem.
The Roon guide advises that the appropriate file can be obtained form this address (http://johnvansickle.com/ffmpeg/). However when I go to this location, it isn’t obvious which file I need for Roon on my Intel NUC (NUC8i5BEH)…

Can anyone advise me which one to download?

(ffmpeg-git-20180711-64bit-static)

Thanks - but that file doesn’t appear in the page of the link (http://johnvansickle.com/ffmpeg) provided by the Roon guide.

The two builds are and and i686. You want an i686.
https://johnvansickle.com/ffmpeg/builds/ffmpeg-git-i686-static.tar.xz

Thanks again.

1 Like

You definitely do not want the i686 build-- that is 32bit.

You want the amd64 build.

It is directly linked from here: https://kb.roonlabs.com/Roon_OS_Missing_Codecs

1 Like

Sorry my bad.

Thanks for pointing this out. I assume I can just replace the file in file I have placed in the Codecs folder with the more appropriate version?

yes you can.

amd64 makes sense if you know your computer history. AMD developed the 64-bit extension to the x86 “architecture”.

Okay - thank you.

Although I have to say that it is a bit of an assumption on the part of the developer and the Roon Rock installation guide writers that everyone should be aware of this.

You don’t have to be aware of this: step 1 of the ‘Adding the Codecs – step by step’ section offers a direct link to the correct version:

https://johnvansickle.com/ffmpeg/builds/ffmpeg-git-64bit-static.tar.xz