Roon Rock issues with Audio Devices - none found / shown

Rock (last version) is having serious issues with connecting to audio devices. Had various other issues. I reinstalled (using the Rock web interface), reset the database/settings, etc. All seemed fine. Even could configure audio devices, which now all disappeared. Cant’t manage the either. Disconnected the USB DACs, reconnected, restarted. No success.

This is really rare, but usually happens in the case of a corrupt db that is preventing the rest of the Core to load up.

Do you have older backups you can try to restore from?

I had all of my audio connections disappear. Reinstalling the ROCK operating system worked for me. YRMV

I tried to restore. It did not help. Resetting the database (via the web portal) failed (exit code 2) at least that was the message I got. But it seemed to do something because I had to reconfigure, but that led to nothing. Same issue.

Now trying to restore an even older backup. The SMB share had fewer folders in the root of Data. Will come back if this restore helps. Previous restores seemed to worked but at a later stage led to the same issues.

ugh… sounds like you have a failing ssd

Really? It is a brand new one. Is there a way to check this?

BTW, the restore of the older backup helped. All seems okay now. When this started I noticed a strange thing in the file system of the SMB share (Data). Somewhere in the folder structure (in InternalStorage and then a folder with music in it) the root folder structure of the Rock appeared.

Could it be that the file structure of your SSD has become corrupted? I had something like this happen to me a while back:

Could be the case, Geoff. I also saw that not all folders were there (RoonServer for example was missing). That is why I reinstalled ROCK (via the web portal). This was successful. But then the issues started with he Audio Devices. Now all seems to be stable, but loading the Overview page takes longer than before.

Do you know if there is a way to see in the logs if there is an issue with the SSD?

Sorry, I don’t. You might want to open a support case with Roon Labs by making a post in the Support Category of the forum, and giving details of your setup and network. They can advise you better than I.

Ok. Thanks. I will monitor it a little more today and depending on what I see contact support.

Could this also be a bad DIMM? I actually had that problem with my ROCK build…confirmed by booting Ubuntu via thumbdrive and running memtest86+. I just don’t recall the error code that I saw when restoring the database.

Thanks, David. That is a clever way to check the status of the SSD and DIMM. Will try this.

Sure. This takes several hours to check the memory (RAM DIMMs). I’m not aware of a similar test for the SSD.

I am having the same problem. My Intel NUC ROCK enabled server was working fine earlier during the day, but when I revisited it, I get the same “Manage Audio Devices” message, and when I clicked on “Manage Audio Devices”, I get that same blank view that Maarten_Boerma got. It’s crazy making!

What’s more frustrating is that I’m not only using this for personal use, but reviews. I am currently reviewing the Ayre QB-9 Twenty DAC with it, but cannot see it now. I don’t have backups. What can I do?

For me the issues were solved putting back a backup. Not the most recent one (that was corrupted too, I think), but an older one.

Hi Maarten,

Thanks! I found a backup and restored it, then did another restore after it worked. Problem solved!



1 Like