Roon Rock not updating from newly installed NUC from 1.7 to 1.8

Core Machine (Operating system/System info/Roon build number)

Intel Nuc NUC8i3BEK2 dedicated server

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired network, fixed IP

Router Asus RT-AC87U

Description Of Issue

I’ve reinstalled my NUC with Roon Rock freshly downloaded.
The Roon version of the installer still seems to be version 1.7 build 571.

On startup of the remote, the update is unreachable or seems to be blocked somewhere.
Tried several times over 2 hours to reboot the NUC, restart the Roon server, reinstall the OS. Nothing seems to help.


You’re using DHCP with the NUC not a fixed IP address. Can you confirm that the default gateway is correct? On your Mac, go to System Preferences > Network > Advanced > TCP/IP and share the IP address (Router/ Gateway) highlighted here.

If this is indeed then I would try changing the DNS server to to see if that helps.

My router sits on The nuc uses dhcp, but the fixed IP is set by the router for every fixed asset (computers, endpoints,…) The dhcp range is limited to the range…200 for Phones and tablets. I know a bit of networks. I have access to the Roon rock via smb on that ip adress. The only thing I can think of is that there is a dns entry somewhere that doesn’t match the rock server.

Hi Pieter,

Click the Reinstall button of the Operating System from the WebUI and see if that upgrades your ROCK.

Cheers, Greg

Thanks, the change of the dns server worked. I already had flushed al my dns caches on the router etc… but that one I couldn’t.
Everything’s working fine now

That one didn’t work. Update only worked with a different dns server. Thanks anyway.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.