ROON ROCK NUC not accessing network

Am following the pages you link…tried a few times but the software wasn’t overwritten and the install menu never shows up…hence my query…do I need to re-format the Boot SSD before the software will write to the drive? Is the format of the USB stick in any way important?

@Wdw - You shouldn’t have to reformat the SSD because booting off the flash drive is supposed to take care of that step. When you boot off of the flash drive, what are the options presented? It might be easier if you share a screenshot (instructions on how to upload images can be found here).

I would expect the same build to show up after reinstalling the OS since you were on build 390 before and will remain on build 390 afterwards.

Is the same IP address range showing up on your monitor after flashing it or does it change to the 192.168.1.XXX range? Have you removed the additional USB to Ethernet converter?


Hello Noris,
Am now rebooting and re-installing. After multiple attempts to reach the install menu but getting error messages, it became clear the format of the USB drive (Fat32) was important. After reformatting and creating a new disc image, the reinstall worked as intended. I would like to keep the static IP so I assume, as per Fishgutz’z comments above, I should revise my router settings accordingly.

1 Like

@Wdw - It’s true you shouldn’t have a static IP without address reservation (although you can have address reservation without a static IP), but the question is whether you really need a static IP.

@noris ?

Hello Slim, Thanks for your help…learned a few things with your help.
I had used the ETH/USB device to eliminate the switch which would sit “after” the ROON ROCK…so that device allows the ethernet to come from a switch further up-line, go to the ROCK then out by ethernet directly to my DAC.
Has been working but this little fiasco made this problematic. I have now reintroduced the later switch but would still like to pursue the use of the ETH/USB device. I did finally log into my router with your help and there was a page that allows for a static address for one or two devices. Asked for the IP but also the MAC ADDRESS…aren’t these addresses more difficult to find with the later Apple releases?

Apple did something so that Fing can no longer find MACDs, you’re right.

Once you’re in your router software, there should be a list of connected devices. You can get ROCK’s IP and MACD there.

Still a little confusion. The way I would do it is to not set a static id anywhere, either in ROCK or in your router. Instead, just reserve the IP address in your router. That, if your router software allows it, will accomplish what you want.

BTW - I don’t believe you buy any SQ by avoiding a switch, I go thru several. People will agree/disagree about this. Just saying…

Trudat…it’s just those noisy SMPS … audio-nervousa for sure.


1 Like

Hello @Wdw/@xxx,

My recommendation would be the same as Slim’s – to not use Static Mode at all if you can avoid it, Reserved IP addresses accomplish the same thing but also have the flexibility to adjust to other networks and still maintain a connection if the subnet range were ever to change.

@Wdw - Can I ask what prevents you from using the Ethernet in from the ROCK and add a simple unmanaged switch before the connection feeds into the ROCK? Since the router is still handling DHCP, both ROCK and Endpoint should be able to see each other through a switch as long as the endpoint is configured for DHCP. Also, you should be able to find the MAC ID of the ROCK and Endpoint in the Router’s DHCP table and assign it a reserved IP there too.

I hope this helps.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.