Roon ROCK on Intel NUC doesn't recognize Qnap TR-002

Roon Core Machine

Roon ROCK on Intel NUC 10th generation
Qnap TR-002 DAS (not NAS)

Networking Gear & Setup Details

not issue with networking

Connected Audio Devices

not issue with audio devices

Number of Tracks in Library

15000 albums large library

Description of Issue

i have been using this Intel NUC based Roon ROCK for 2-3 years. only issue is that i don’t like it scans entire storage folders on regular basis when storage folders are on NAS. therefore i switched to DAS. I firstly used a portable 2.5 inch HDD, not enough storage to put all my albums on it. I then brought this Qnap TR-002 which is a 2-bay DAS. Now I can use large-sized 3.5 inch HDDs to store my music library.

I then put the 2 18-TB Seagate Ironwolf NAS HDDs in the TR-002 and set it to run on RAID 0, then formatted the file system to be exFAT, so that it may be able to directly connected to my Windows PC and Mac when needed.

However, when I connect the TR-002 with my NUC, it seems that NUC doesn’t recognize TR-002 as exteral storage. I went to the storage folder of ROCK system but there is no storage folder in it.

in the meantime, the other portable 2.5 inch HDD formated exFAT works well. and the TR-002 works well with my Windows PC and my Mac.

Now I can only guess that this may not be an issue with my devices but in the above setup, The QNAP DAS doesn’t work with Roon ROCK.

is there a way I can make them work? or it’d be better that I ask for QNAP support?

thanks
Sam

Do you use hardware RAID mode?
Note: For the software RAID mode external software (QNAP and/or OS) is needed and therefore is unlikely to work.

Else, try JBOD. Also how is the DAS connected (USB-A or USB-C)? AFAIK were USB-C connectors disbled with ROCK in the past.

I suspect the QNAP TR-002 requires device drivers that are not available with ROCK.

Moreover, it appears that this device is designed to expand an existing QNAP NAS.

Hardware RAID and USB-A

It’s more than a NAS expansion, which also works as a DAS with windows, Mac and Linux. It does work just like any other external storage with my windows PC and Mac requiring no driver. I don’t have a linux system to try though.

ROCK is a stripped down bespoke Linux distro, so has limited support for external hardware. You could try a live Linux CD to see if this works with the QNAP. If it does, you may need to switch to, for example, Ubuntu Server, and install Roon Server on this.

issue fixed. I suspect that something went wrong when I first initiated the HDDs on the TR-002. I tried to re-do everything from the beginning and re-copied all my files back to TR-002 and now it works fine with Roon Rock on NUC.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.