Roon Rock on NUC - cannot start server

So I know others have seen this but their solution does work for me. I have a new NUC (NUC10i5FNH1) with 16G RAM and 500G ssd. I was able to boot of the thumb drive and install ROCK just fine. But when I try to access ROCK from the Roon client it tells me that I need to configure the Roon device on my network. When I use the browser to access ROCK’s ip address I get a screen showing that the Roon OS and Database are up and running but the Roon Server Software is not running.

When I try to starting the software via the button I get a message saying it was unable to start. I have reinstalled and restarted multiple times but the Roon Server Software refuses to start.

Any ideas?
Screen shots

Gosh I wish I could help. I ran into this once. I think I just started from scratch in a blind panic that I had spent all this money on a nuc for nothing… and it miraculously just worked even though I think I did nothing different, and it’s been running ever since. But that is awful advice. I hope someone wiser and more experienced than I can tell you something less hopeful and dramatic.

You could try and view the rock network share.

If you can you can see if thee is anything useful in the logs (Data/RoonServer/Logs)

Have you tried pressing the reinstall button on the web page
It just pulls down and installs the latest version of Rock

Michael, thank you for the suggestion but I have tried that 2 or 3 times.

1 Like

Thank you. Unfortunately the Roon server isn’t getting far enough to create the RoonServer directory let alone a put any logs in it. There are many directories under Data but no RoonServer.

Might this suggest an issue with the HD?
I am guessing if you reset the database it’s still not there?

Michael, you are correct. Resetting the DB does not create the RoonServer directory. I am not sure how it could be a HD issue thought as there are many other directories created.

Patrick Roon creates multiple partitions on the drive and the database etc go on the second partition.
Maybe you can do a low level format or analysis on the drive using a usb boot disk

Michael, I’ll give that a try. Thank you!

No problem and good luck

I would like to thank you all for your suggestions. This morning I reformatted the SSD and reinstalled ROCK. It all worked flawlessly! It’s a great start to 2022!


A great start to the new year and I hope it continues that way for you.

Glad to hear it worked!

I hate to say it’s the new “have you tried to reboot the machine?” but maybe in certain cases it is :slight_smile:

Many times. I did a complete reinstall which solved the issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.